summaryrefslogtreecommitdiff
path: root/python-aalam-common.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aalam-common.spec')
-rw-r--r--python-aalam-common.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-aalam-common.spec b/python-aalam-common.spec
new file mode 100644
index 0000000..6a4d1a1
--- /dev/null
+++ b/python-aalam-common.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aalam-common
+Version: 0.1.66
+Release: 1
+Summary: Aalam Common module
+License: MIT
+URL: https://pypi.org/project/aalam-common/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/60/1b5782b709825d43f2c038f3581838bf6c384e916673784f1c39e53ec2aa/aalam-common-0.1.66.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-aalam-common
+Summary: Aalam Common module
+Provides: python-aalam-common
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aalam-common
+
+
+%package help
+Summary: Development documents and examples for aalam-common
+Provides: python3-aalam-common-doc
+%description help
+
+
+%prep
+%autosetup -n aalam-common-0.1.66
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aalam-common -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.66-1
+- Package Spec generated