summaryrefslogtreecommitdiff
path: root/python-abilian-sbe.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-abilian-sbe.spec')
-rw-r--r--python-abilian-sbe.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-abilian-sbe.spec b/python-abilian-sbe.spec
new file mode 100644
index 0000000..8003442
--- /dev/null
+++ b/python-abilian-sbe.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-abilian-sbe
+Version: 0.5.21
+Release: 1
+Summary: Social Business platform (entreprise collaboration and information management)
+License: LGPL-2.0-or-later
+URL: https://github.com/abilian/abilian-sbe
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a0/9d/b8f57c2a0370b8e3ceb672bd24d34ef142589797a4b639daa2ccb86cf1a9/abilian-sbe-0.5.21.tar.gz
+BuildArch: noarch
+
+Requires: python3-abilian-core
+Requires: python3-chardet
+Requires: python3-flask-babel
+Requires: python3-html2text
+Requires: python3-itsdangerous
+Requires: python3-jinja2
+Requires: python3-langid
+Requires: python3-markdown
+Requires: python3-openpyxl
+Requires: python3-toolz
+Requires: python3-validate_email
+Requires: python3-wtforms
+Requires: python3-xlwt
+
+%description
+Abilian SBE (Social Business Engine) is a platform for social business applications, and more specifically collaborative / enterprise 2.0 business applications, such as enterprise social networks (ESN).
+Abilian SBE revolves around the concept of *communities*, which are collaborative spaces with services such as lightweight document management, discussions, wikis, user timelines, etc.
+It is based on the `Abilian Core <http://abilian-core.readthedocs.org/en/latest/>`_ project which provide the basic services, on top of Flask and SQLAlchemy.
+Abilian SBE is used by several major customers in production, since mid 2013.
+
+%package -n python3-abilian-sbe
+Summary: Social Business platform (entreprise collaboration and information management)
+Provides: python-abilian-sbe
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-abilian-sbe
+Abilian SBE (Social Business Engine) is a platform for social business applications, and more specifically collaborative / enterprise 2.0 business applications, such as enterprise social networks (ESN).
+Abilian SBE revolves around the concept of *communities*, which are collaborative spaces with services such as lightweight document management, discussions, wikis, user timelines, etc.
+It is based on the `Abilian Core <http://abilian-core.readthedocs.org/en/latest/>`_ project which provide the basic services, on top of Flask and SQLAlchemy.
+Abilian SBE is used by several major customers in production, since mid 2013.
+
+%package help
+Summary: Development documents and examples for abilian-sbe
+Provides: python3-abilian-sbe-doc
+%description help
+Abilian SBE (Social Business Engine) is a platform for social business applications, and more specifically collaborative / enterprise 2.0 business applications, such as enterprise social networks (ESN).
+Abilian SBE revolves around the concept of *communities*, which are collaborative spaces with services such as lightweight document management, discussions, wikis, user timelines, etc.
+It is based on the `Abilian Core <http://abilian-core.readthedocs.org/en/latest/>`_ project which provide the basic services, on top of Flask and SQLAlchemy.
+Abilian SBE is used by several major customers in production, since mid 2013.
+
+%prep
+%autosetup -n abilian-sbe-0.5.21
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-abilian-sbe -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.21-1
+- Package Spec generated