summaryrefslogtreecommitdiff
path: root/python-accuweather.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-21 02:07:18 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-21 02:07:18 +0000
commiteb52f360c9178ea6a9d12907edf506a48a03f863 (patch)
tree36aa6c87e49a958e2718628b35b2d88c67ac3322 /python-accuweather.spec
parent2bbbf25070e6c8832f7d052bf90ac4cfb55192a7 (diff)
automatic import of python-accuweatheropeneuler20.03
Diffstat (limited to 'python-accuweather.spec')
-rw-r--r--python-accuweather.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/python-accuweather.spec b/python-accuweather.spec
index 4479bfe..ece2b38 100644
--- a/python-accuweather.spec
+++ b/python-accuweather.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-accuweather
-Version: 0.5.0
+Version: 0.5.1
Release: 1
Summary: Python wrapper for getting weather data from AccuWeather servers.
License: Apache-2.0 License
URL: https://github.com/bieniu/accuweather
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/66/6f/090f3b2063e44b2ed9eb4188d6b414dadb69fe0d64a1a349fa89e1775b93/accuweather-0.5.0.tar.gz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cc/76/b2336d769b48a9e19cba13a73469520cdb6789a2765a98e9beaf8aa7f647/accuweather-0.5.1.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
@@ -30,6 +30,7 @@ To generate API key go to https://developer.accuweather.com/user/register and af
## How to use package
```python
+"""Example of usage."""
import asyncio
import logging
@@ -52,6 +53,7 @@ logging.basicConfig(level=logging.DEBUG)
async def main():
+ """Run main function."""
async with ClientSession() as websession:
try:
accuweather = AccuWeather(
@@ -79,7 +81,6 @@ async def main():
loop = asyncio.new_event_loop()
loop.run_until_complete(main())
loop.close()
-
```
[releases]: https://github.com/bieniu/accuweather/releases
@@ -119,6 +120,7 @@ To generate API key go to https://developer.accuweather.com/user/register and af
## How to use package
```python
+"""Example of usage."""
import asyncio
import logging
@@ -141,6 +143,7 @@ logging.basicConfig(level=logging.DEBUG)
async def main():
+ """Run main function."""
async with ClientSession() as websession:
try:
accuweather = AccuWeather(
@@ -168,7 +171,6 @@ async def main():
loop = asyncio.new_event_loop()
loop.run_until_complete(main())
loop.close()
-
```
[releases]: https://github.com/bieniu/accuweather/releases
@@ -205,6 +207,7 @@ To generate API key go to https://developer.accuweather.com/user/register and af
## How to use package
```python
+"""Example of usage."""
import asyncio
import logging
@@ -227,6 +230,7 @@ logging.basicConfig(level=logging.DEBUG)
async def main():
+ """Run main function."""
async with ClientSession() as websession:
try:
accuweather = AccuWeather(
@@ -254,7 +258,6 @@ async def main():
loop = asyncio.new_event_loop()
loop.run_until_complete(main())
loop.close()
-
```
[releases]: https://github.com/bieniu/accuweather/releases
@@ -270,7 +273,7 @@ loop.close()
%prep
-%autosetup -n accuweather-0.5.0
+%autosetup -n accuweather-0.5.1
%build
%py3_build
@@ -310,5 +313,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.0-1
+* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
- Package Spec generated