summaryrefslogtreecommitdiff
path: root/python-actdiag.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:06:01 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:06:01 +0000
commit47e0a6cfab6605db048c8ac984d516386acf8e83 (patch)
tree855d16fe5c02c8cc86dee0d71f506ae715f394e5 /python-actdiag.spec
parente52927c2fbd6eb00827035b5bf63eaaf68ca9ac0 (diff)
automatic import of python-actdiag
Diffstat (limited to 'python-actdiag.spec')
-rw-r--r--python-actdiag.spec91
1 files changed, 91 insertions, 0 deletions
diff --git a/python-actdiag.spec b/python-actdiag.spec
new file mode 100644
index 0000000..3ca74e3
--- /dev/null
+++ b/python-actdiag.spec
@@ -0,0 +1,91 @@
+%global _empty_manifest_terminate_build 0
+Name: python-actdiag
+Version: 3.0.0
+Release: 1
+Summary: actdiag generates activity-diagram image from text
+License: Apache License 2.0
+URL: http://blockdiag.com/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6d/19/7511fa0a0048ddb56966e2ef9bcd0971a9496cbdb1487b0b3e16a79f7acb/actdiag-3.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-blockdiag
+Requires: python3-docutils
+Requires: python3-nose
+Requires: python3-pep8
+Requires: python3-reportlab
+Requires: python3-docutils
+Requires: python3-flake8
+Requires: python3-flake8-coding
+Requires: python3-flake8-copyright
+Requires: python3-flake8-isort
+
+%description
+* Generate activity-diagram from dot like text (basic feature).
+* Multilingualization for node-label (utf-8 only).
+You can get some examples and generated images on
+`blockdiag.com <http://blockdiag.com/actdiag/build/html/index.html>`_ .
+
+%package -n python3-actdiag
+Summary: actdiag generates activity-diagram image from text
+Provides: python-actdiag
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-actdiag
+* Generate activity-diagram from dot like text (basic feature).
+* Multilingualization for node-label (utf-8 only).
+You can get some examples and generated images on
+`blockdiag.com <http://blockdiag.com/actdiag/build/html/index.html>`_ .
+
+%package help
+Summary: Development documents and examples for actdiag
+Provides: python3-actdiag-doc
+%description help
+* Generate activity-diagram from dot like text (basic feature).
+* Multilingualization for node-label (utf-8 only).
+You can get some examples and generated images on
+`blockdiag.com <http://blockdiag.com/actdiag/build/html/index.html>`_ .
+
+%prep
+%autosetup -n actdiag-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-actdiag -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated