summaryrefslogtreecommitdiff
path: root/python-adb-shell.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-adb-shell.spec')
-rw-r--r--python-adb-shell.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-adb-shell.spec b/python-adb-shell.spec
new file mode 100644
index 0000000..d4a2bdc
--- /dev/null
+++ b/python-adb-shell.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-adb-shell
+Version: 0.4.3
+Release: 1
+Summary: A Python implementation of ADB with shell and FileSync functionality.
+License: Apache Software License
+URL: https://github.com/JeffLIrion/adb_shell
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9d/ba/7cdd068d6ac371c9de00c52262b27c1648248bb3cd6386e94a890a2cf045/adb_shell-0.4.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-cryptography
+Requires: python3-pyasn1
+Requires: python3-rsa
+Requires: python3-aiofiles
+Requires: python3-libusb1
+
+%description
+Documentation for this package can be found at https://adb-shell.readthedocs.io/.
+Prebuilt wheel can be downloaded from `nightly.link <https://nightly.link/JeffLIrion/adb_shell/workflows/python-package/master/wheel.zip>`_.
+This Python package implements ADB shell and FileSync functionality. It originated from `python-adb <https://github.com/google/python-adb>`_.
+
+%package -n python3-adb-shell
+Summary: A Python implementation of ADB with shell and FileSync functionality.
+Provides: python-adb-shell
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-adb-shell
+Documentation for this package can be found at https://adb-shell.readthedocs.io/.
+Prebuilt wheel can be downloaded from `nightly.link <https://nightly.link/JeffLIrion/adb_shell/workflows/python-package/master/wheel.zip>`_.
+This Python package implements ADB shell and FileSync functionality. It originated from `python-adb <https://github.com/google/python-adb>`_.
+
+%package help
+Summary: Development documents and examples for adb-shell
+Provides: python3-adb-shell-doc
+%description help
+Documentation for this package can be found at https://adb-shell.readthedocs.io/.
+Prebuilt wheel can be downloaded from `nightly.link <https://nightly.link/JeffLIrion/adb_shell/workflows/python-package/master/wheel.zip>`_.
+This Python package implements ADB shell and FileSync functionality. It originated from `python-adb <https://github.com/google/python-adb>`_.
+
+%prep
+%autosetup -n adb-shell-0.4.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-adb-shell -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.3-1
+- Package Spec generated