summaryrefslogtreecommitdiff
path: root/python-aeropress.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aeropress.spec')
-rw-r--r--python-aeropress.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-aeropress.spec b/python-aeropress.spec
new file mode 100644
index 0000000..db14f88
--- /dev/null
+++ b/python-aeropress.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aeropress
+Version: 0.0.43
+Release: 1
+Summary: Helper for deploying Docker images to AWS ECS.
+License: BSD License
+URL: https://github.com/muraty/aeropress
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/db/63/dc24eda4fa8a4177de7d35322e1b0ed8d5fd19b343ca1f9302b7aea51ab4/aeropress-0.0.43.tar.gz
+BuildArch: noarch
+
+
+%description
+``aeropress`` is a CLI program for deploying Docker images to AWS ECS. It receives a folder path that includes
+ECS task and service definitions and then does the jobs respectively;
+ - Register ECS task definitions
+ - Create Cloudwatch metrics for scaling policies
+ - Create or update scaling policies for ECS services
+ - Create or update alarms on Cloudwatch
+ - Create or update ECS services
+
+%package -n python3-aeropress
+Summary: Helper for deploying Docker images to AWS ECS.
+Provides: python-aeropress
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aeropress
+``aeropress`` is a CLI program for deploying Docker images to AWS ECS. It receives a folder path that includes
+ECS task and service definitions and then does the jobs respectively;
+ - Register ECS task definitions
+ - Create Cloudwatch metrics for scaling policies
+ - Create or update scaling policies for ECS services
+ - Create or update alarms on Cloudwatch
+ - Create or update ECS services
+
+%package help
+Summary: Development documents and examples for aeropress
+Provides: python3-aeropress-doc
+%description help
+``aeropress`` is a CLI program for deploying Docker images to AWS ECS. It receives a folder path that includes
+ECS task and service definitions and then does the jobs respectively;
+ - Register ECS task definitions
+ - Create Cloudwatch metrics for scaling policies
+ - Create or update scaling policies for ECS services
+ - Create or update alarms on Cloudwatch
+ - Create or update ECS services
+
+%prep
+%autosetup -n aeropress-0.0.43
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aeropress -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.43-1
+- Package Spec generated