summaryrefslogtreecommitdiff
path: root/python-aijidevtools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aijidevtools.spec')
-rw-r--r--python-aijidevtools.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/python-aijidevtools.spec b/python-aijidevtools.spec
new file mode 100644
index 0000000..aa55328
--- /dev/null
+++ b/python-aijidevtools.spec
@@ -0,0 +1,88 @@
+%global _empty_manifest_terminate_build 0
+Name: python-AIJIdevtools
+Version: 1.4.4
+Release: 1
+Summary: Some useful helper-funcs for devpers
+License: MIT License
+URL: https://github.com/AIJIJI/devtools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0f/db/c981d7fcddb5c817f30f8e882eb8ae1631c479d9bfd879d5a541df4ff8b6/AIJIdevtools-1.4.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-sh
+Requires: python3-sqlparse
+Requires: python3-termcolor
+Requires: python3-requests
+
+%description
+Some useful helper-funcs for devpers.
+Sub-package is the extension of corresponding package with the same name.
+
+
+
+
+%package -n python3-AIJIdevtools
+Summary: Some useful helper-funcs for devpers
+Provides: python-AIJIdevtools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-AIJIdevtools
+Some useful helper-funcs for devpers.
+Sub-package is the extension of corresponding package with the same name.
+
+
+
+
+%package help
+Summary: Development documents and examples for AIJIdevtools
+Provides: python3-AIJIdevtools-doc
+%description help
+Some useful helper-funcs for devpers.
+Sub-package is the extension of corresponding package with the same name.
+
+
+
+
+%prep
+%autosetup -n AIJIdevtools-1.4.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-AIJIdevtools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.4-1
+- Package Spec generated