summaryrefslogtreecommitdiff
path: root/python-aikif.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aikif.spec')
-rw-r--r--python-aikif.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-aikif.spec b/python-aikif.spec
new file mode 100644
index 0000000..f8f5633
--- /dev/null
+++ b/python-aikif.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-AIKIF
+Version: 0.2.2
+Release: 1
+Summary: Artificial Intelligence Knowledge Information Framework
+License: GNU General Public License v3 (GPLv3)
+URL: https://github.com/acutesoftware/AIKIF
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e6/c6/ac889da6c783b6ece5313bc911d693f28640057423e8e8241e0f9f863289/AIKIF-0.2.2.tar.gz
+BuildArch: noarch
+
+
+%description
+>> pip install aikif
+or get latest info from https://github.com/acutesoftware/AIKIF
+
+%package -n python3-AIKIF
+Summary: Artificial Intelligence Knowledge Information Framework
+Provides: python-AIKIF
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-AIKIF
+>> pip install aikif
+or get latest info from https://github.com/acutesoftware/AIKIF
+
+%package help
+Summary: Development documents and examples for AIKIF
+Provides: python3-AIKIF-doc
+%description help
+>> pip install aikif
+or get latest info from https://github.com/acutesoftware/AIKIF
+
+%prep
+%autosetup -n AIKIF-0.2.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-AIKIF -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.2-1
+- Package Spec generated