summaryrefslogtreecommitdiff
path: root/python-aiomqtt.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aiomqtt.spec')
-rw-r--r--python-aiomqtt.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-aiomqtt.spec b/python-aiomqtt.spec
new file mode 100644
index 0000000..06fcdc6
--- /dev/null
+++ b/python-aiomqtt.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aiomqtt
+Version: 0.1.3
+Release: 1
+Summary: An AsyncIO asynchronous wrapper around paho-mqtt.
+License: Eclipse Public License v1.0 / Eclipse Distribution License v1.0
+URL: https://github.com/mossblaser/aiomqtt
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c6/a7/af5d18fe8a6d3b92f9801867ec41b2bbaf89d7d70ddd62af44d7ebb7d107/aiomqtt-0.1.3.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-aiomqtt
+Summary: An AsyncIO asynchronous wrapper around paho-mqtt.
+Provides: python-aiomqtt
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aiomqtt
+
+
+%package help
+Summary: Development documents and examples for aiomqtt
+Provides: python3-aiomqtt-doc
+%description help
+
+
+%prep
+%autosetup -n aiomqtt-0.1.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aiomqtt -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3-1
+- Package Spec generated