summaryrefslogtreecommitdiff
path: root/python-aioodbc.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:11:43 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:11:43 +0000
commita7405b075454bee13ebfafb928d0209560127d81 (patch)
treed4b5adb9a4e91ce19016c4c75938d6440c446160 /python-aioodbc.spec
parentfbd77ecde5e580295a4e01afb01229bff118d5d8 (diff)
automatic import of python-aioodbc
Diffstat (limited to 'python-aioodbc.spec')
-rw-r--r--python-aioodbc.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-aioodbc.spec b/python-aioodbc.spec
new file mode 100644
index 0000000..9effdfb
--- /dev/null
+++ b/python-aioodbc.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aioodbc
+Version: 0.3.3
+Release: 1
+Summary: ODBC driver for asyncio.
+License: Apache 2
+URL: https://github.com/aio-libs/aioodbc
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0f/d9/1e4d1582a059f72b24a0bcad08c6aec8109a6d69e888155a7968833abe91/aioodbc-0.3.3.tar.gz
+BuildArch: noarch
+
+
+%description
+**aioodbc** is a Python 3.5+ module that makes it possible to access ODBC_ databases
+with asyncio_. It relies on the awesome pyodbc_ library and preserves the same look and
+feel. *aioodbc* was written using `async/await` syntax (PEP492_) and thus is not compatible
+with Python versions older than 3.5. Internally *aioodbc* employs threads to avoid
+blocking the event loop, threads_ are not that as bad as you think!. Other
+drivers like motor_ use the same approach.
+**aioodbc** is fully compatible and tested with uvloop_. Take a look at the test
+suite, all tests are executed with both the default event loop and uvloop_.
+
+%package -n python3-aioodbc
+Summary: ODBC driver for asyncio.
+Provides: python-aioodbc
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aioodbc
+**aioodbc** is a Python 3.5+ module that makes it possible to access ODBC_ databases
+with asyncio_. It relies on the awesome pyodbc_ library and preserves the same look and
+feel. *aioodbc* was written using `async/await` syntax (PEP492_) and thus is not compatible
+with Python versions older than 3.5. Internally *aioodbc* employs threads to avoid
+blocking the event loop, threads_ are not that as bad as you think!. Other
+drivers like motor_ use the same approach.
+**aioodbc** is fully compatible and tested with uvloop_. Take a look at the test
+suite, all tests are executed with both the default event loop and uvloop_.
+
+%package help
+Summary: Development documents and examples for aioodbc
+Provides: python3-aioodbc-doc
+%description help
+**aioodbc** is a Python 3.5+ module that makes it possible to access ODBC_ databases
+with asyncio_. It relies on the awesome pyodbc_ library and preserves the same look and
+feel. *aioodbc* was written using `async/await` syntax (PEP492_) and thus is not compatible
+with Python versions older than 3.5. Internally *aioodbc* employs threads to avoid
+blocking the event loop, threads_ are not that as bad as you think!. Other
+drivers like motor_ use the same approach.
+**aioodbc** is fully compatible and tested with uvloop_. Take a look at the test
+suite, all tests are executed with both the default event loop and uvloop_.
+
+%prep
+%autosetup -n aioodbc-0.3.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aioodbc -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.3-1
+- Package Spec generated