summaryrefslogtreecommitdiff
path: root/python-aiosnmp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aiosnmp.spec')
-rw-r--r--python-aiosnmp.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-aiosnmp.spec b/python-aiosnmp.spec
new file mode 100644
index 0000000..a74e022
--- /dev/null
+++ b/python-aiosnmp.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aiosnmp
+Version: 0.7.2
+Release: 1
+Summary: asyncio SNMP client
+License: MIT
+URL: https://github.com/hh-h/aiosnmp
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d5/54/c38bc520e7eb75f91ad76d1b7e17e23145d34f18e6059a1eac228f33e2dd/aiosnmp-0.7.2.tar.gz
+
+
+%description
+aiosnmp is an asynchronous SNMP client for use with asyncio.
+
+%package -n python3-aiosnmp
+Summary: asyncio SNMP client
+Provides: python-aiosnmp
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-aiosnmp
+aiosnmp is an asynchronous SNMP client for use with asyncio.
+
+%package help
+Summary: Development documents and examples for aiosnmp
+Provides: python3-aiosnmp-doc
+%description help
+aiosnmp is an asynchronous SNMP client for use with asyncio.
+
+%prep
+%autosetup -n aiosnmp-0.7.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aiosnmp -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.2-1
+- Package Spec generated