summaryrefslogtreecommitdiff
path: root/python-airtouch4pyapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-airtouch4pyapi.spec')
-rw-r--r--python-airtouch4pyapi.spec208
1 files changed, 208 insertions, 0 deletions
diff --git a/python-airtouch4pyapi.spec b/python-airtouch4pyapi.spec
new file mode 100644
index 0000000..f951ac1
--- /dev/null
+++ b/python-airtouch4pyapi.spec
@@ -0,0 +1,208 @@
+%global _empty_manifest_terminate_build 0
+Name: python-airtouch4pyapi
+Version: 1.0.8
+Release: 1
+Summary: An api allowing control of AC state (temperature, on/off, mode) of an Airtouch 4 controller locally over TCP
+License: MIT License
+URL: https://github.com/LonePurpleWolf/airtouch4pyapi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1b/e9/f16962de46563a761d12d79f697d3fa1f34210a3e2776209257c85b90430/airtouch4pyapi-1.0.8.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+
+%description
+# Airtouch 4 & 5 Python TCP API
+An api allowing control of AC state (temperature, on/off, mode) of an Airtouch 4 controller locally over TCP. Airtouch 5 support is experimental as of 28 Nov 2022, and is fully interface compatible with AT4.
+
+All you need to do is initialise and specify the correct AirTouchVersion (if you don't, it assumes 4).
+
+## Warning
+I am using this with my own Airtouch 4 and see no issues. Please don't blame me if you have any issues with your Airtouch 4 or AC system after using this - I don't know much about AC systems and will probably not be able to help!
+
+Others are using it with Airtouch 5 and see no issues.
+
+## Usage
+To initialise:
+* `airTouch = AirTouch("192.168.1.19")`
+* `airTouch = AirTouch("192.168.1.1", AirTouchVersion.AIRTOUCH5)`
+
+As a test:
+
+Use the demo.py file and pass in an AirTouch IP. It takes you through a few tests.
+
+## Notes
+AirTouch5: If you turn off all zones, the AC itself turns off. Turning on a zone does not turn the AC back on by itself. You must turn it back on too. Same behaviour in 'official' app.
+
+To load:
+* `await airTouch.UpdateInfo();` -- This loads the config from the AirTouch. Make sure you check for any errors before using it. It will load the Group/Zone info, the AC info, then capabilities. This needs to happen prior to using.
+
+The following functions are available:
+
+Group Level Functions:
+* `SetGroupToTemperature` (async)
+* `TurnGroupOn` (async)
+* `TurnGroupOff` (async)
+* `SetCoolingModeByGroup` (async)
+* `SetFanSpeedByGroup` (async)
+* `GetSupportedCoolingModesByGroup` -- Based on the loaded config.
+* `GetSupportedFanSpeedsByGroup` -- Based on the loaded config.
+
+AC Level Functions
+* `TurnAcOn` (async)
+* `TurnAcOff` (async)
+* `SetFanSpeedForAc` (async)
+* `SetCoolingModeForAc` (async)
+* `GetSupportedCoolingModesForAc`
+* `GetSupportedFanSpeedsForAc`
+* `GetAcs`
+
+
+
+%package -n python3-airtouch4pyapi
+Summary: An api allowing control of AC state (temperature, on/off, mode) of an Airtouch 4 controller locally over TCP
+Provides: python-airtouch4pyapi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-airtouch4pyapi
+# Airtouch 4 & 5 Python TCP API
+An api allowing control of AC state (temperature, on/off, mode) of an Airtouch 4 controller locally over TCP. Airtouch 5 support is experimental as of 28 Nov 2022, and is fully interface compatible with AT4.
+
+All you need to do is initialise and specify the correct AirTouchVersion (if you don't, it assumes 4).
+
+## Warning
+I am using this with my own Airtouch 4 and see no issues. Please don't blame me if you have any issues with your Airtouch 4 or AC system after using this - I don't know much about AC systems and will probably not be able to help!
+
+Others are using it with Airtouch 5 and see no issues.
+
+## Usage
+To initialise:
+* `airTouch = AirTouch("192.168.1.19")`
+* `airTouch = AirTouch("192.168.1.1", AirTouchVersion.AIRTOUCH5)`
+
+As a test:
+
+Use the demo.py file and pass in an AirTouch IP. It takes you through a few tests.
+
+## Notes
+AirTouch5: If you turn off all zones, the AC itself turns off. Turning on a zone does not turn the AC back on by itself. You must turn it back on too. Same behaviour in 'official' app.
+
+To load:
+* `await airTouch.UpdateInfo();` -- This loads the config from the AirTouch. Make sure you check for any errors before using it. It will load the Group/Zone info, the AC info, then capabilities. This needs to happen prior to using.
+
+The following functions are available:
+
+Group Level Functions:
+* `SetGroupToTemperature` (async)
+* `TurnGroupOn` (async)
+* `TurnGroupOff` (async)
+* `SetCoolingModeByGroup` (async)
+* `SetFanSpeedByGroup` (async)
+* `GetSupportedCoolingModesByGroup` -- Based on the loaded config.
+* `GetSupportedFanSpeedsByGroup` -- Based on the loaded config.
+
+AC Level Functions
+* `TurnAcOn` (async)
+* `TurnAcOff` (async)
+* `SetFanSpeedForAc` (async)
+* `SetCoolingModeForAc` (async)
+* `GetSupportedCoolingModesForAc`
+* `GetSupportedFanSpeedsForAc`
+* `GetAcs`
+
+
+
+%package help
+Summary: Development documents and examples for airtouch4pyapi
+Provides: python3-airtouch4pyapi-doc
+%description help
+# Airtouch 4 & 5 Python TCP API
+An api allowing control of AC state (temperature, on/off, mode) of an Airtouch 4 controller locally over TCP. Airtouch 5 support is experimental as of 28 Nov 2022, and is fully interface compatible with AT4.
+
+All you need to do is initialise and specify the correct AirTouchVersion (if you don't, it assumes 4).
+
+## Warning
+I am using this with my own Airtouch 4 and see no issues. Please don't blame me if you have any issues with your Airtouch 4 or AC system after using this - I don't know much about AC systems and will probably not be able to help!
+
+Others are using it with Airtouch 5 and see no issues.
+
+## Usage
+To initialise:
+* `airTouch = AirTouch("192.168.1.19")`
+* `airTouch = AirTouch("192.168.1.1", AirTouchVersion.AIRTOUCH5)`
+
+As a test:
+
+Use the demo.py file and pass in an AirTouch IP. It takes you through a few tests.
+
+## Notes
+AirTouch5: If you turn off all zones, the AC itself turns off. Turning on a zone does not turn the AC back on by itself. You must turn it back on too. Same behaviour in 'official' app.
+
+To load:
+* `await airTouch.UpdateInfo();` -- This loads the config from the AirTouch. Make sure you check for any errors before using it. It will load the Group/Zone info, the AC info, then capabilities. This needs to happen prior to using.
+
+The following functions are available:
+
+Group Level Functions:
+* `SetGroupToTemperature` (async)
+* `TurnGroupOn` (async)
+* `TurnGroupOff` (async)
+* `SetCoolingModeByGroup` (async)
+* `SetFanSpeedByGroup` (async)
+* `GetSupportedCoolingModesByGroup` -- Based on the loaded config.
+* `GetSupportedFanSpeedsByGroup` -- Based on the loaded config.
+
+AC Level Functions
+* `TurnAcOn` (async)
+* `TurnAcOff` (async)
+* `SetFanSpeedForAc` (async)
+* `SetCoolingModeForAc` (async)
+* `GetSupportedCoolingModesForAc`
+* `GetSupportedFanSpeedsForAc`
+* `GetAcs`
+
+
+
+%prep
+%autosetup -n airtouch4pyapi-1.0.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-airtouch4pyapi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.8-1
+- Package Spec generated