summaryrefslogtreecommitdiff
path: root/python-alertnow-python.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-alertnow-python.spec')
-rw-r--r--python-alertnow-python.spec186
1 files changed, 186 insertions, 0 deletions
diff --git a/python-alertnow-python.spec b/python-alertnow-python.spec
new file mode 100644
index 0000000..0ed6844
--- /dev/null
+++ b/python-alertnow-python.spec
@@ -0,0 +1,186 @@
+%global _empty_manifest_terminate_build 0
+Name: python-alertnow-python
+Version: 1.3.3
+Release: 1
+Summary: This package used for logging information and errors.
+License: MIT
+URL: https://gitlab.com/log-collector/alertnow-phyton
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ad/fa/88587bea2a9d799e37092c694be7b2bd297cdf4c08409f4b66a7b80f4938/alertnow-python-1.3.3.tar.gz
+BuildArch: noarch
+
+
+%description
+# AlertNow Python
+This package used for logging information or errors.
+
+#Installation
+```pip install AlertNow-Python```
+
+#How to use it?
+First, you need to register with ```sign-up``` remote API and
+get the api key on the site.
+After, you must initialize connection using ```set_api_key``` and you can initialize host, user and tags data using ```set_host```, ```set_user```, ```set_tag``` method.
+And you can use ```info``` or ```error``` methods.
+
+#Example
+```angular2html
+from logger.src.logger import set_host, set_api_key, set_user, set_tag, info, error
+from logger.src.common.dto.user import User
+from logger.src.common.dto.userGeo import UserGeo
+import jsonpickle
+
+def execute_method():
+ set_host('http://localhost:8080')
+ set_api_key('b4984c8de7f14b2f86f8e036456fd60c')
+ set_tag('os.name', 'python OS')
+ set_user(User(
+ "13213231",
+ "111.11.1.11",
+ UserGeo(
+ "1044",
+ "Baku",
+ "Gadabay"
+ )
+ ))
+
+ response = info('hi from python env')
+ print(response.status_code)
+ print(jsonpickle.encode(response))
+
+execute_method()
+```
+
+%package -n python3-alertnow-python
+Summary: This package used for logging information and errors.
+Provides: python-alertnow-python
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-alertnow-python
+# AlertNow Python
+This package used for logging information or errors.
+
+#Installation
+```pip install AlertNow-Python```
+
+#How to use it?
+First, you need to register with ```sign-up``` remote API and
+get the api key on the site.
+After, you must initialize connection using ```set_api_key``` and you can initialize host, user and tags data using ```set_host```, ```set_user```, ```set_tag``` method.
+And you can use ```info``` or ```error``` methods.
+
+#Example
+```angular2html
+from logger.src.logger import set_host, set_api_key, set_user, set_tag, info, error
+from logger.src.common.dto.user import User
+from logger.src.common.dto.userGeo import UserGeo
+import jsonpickle
+
+def execute_method():
+ set_host('http://localhost:8080')
+ set_api_key('b4984c8de7f14b2f86f8e036456fd60c')
+ set_tag('os.name', 'python OS')
+ set_user(User(
+ "13213231",
+ "111.11.1.11",
+ UserGeo(
+ "1044",
+ "Baku",
+ "Gadabay"
+ )
+ ))
+
+ response = info('hi from python env')
+ print(response.status_code)
+ print(jsonpickle.encode(response))
+
+execute_method()
+```
+
+%package help
+Summary: Development documents and examples for alertnow-python
+Provides: python3-alertnow-python-doc
+%description help
+# AlertNow Python
+This package used for logging information or errors.
+
+#Installation
+```pip install AlertNow-Python```
+
+#How to use it?
+First, you need to register with ```sign-up``` remote API and
+get the api key on the site.
+After, you must initialize connection using ```set_api_key``` and you can initialize host, user and tags data using ```set_host```, ```set_user```, ```set_tag``` method.
+And you can use ```info``` or ```error``` methods.
+
+#Example
+```angular2html
+from logger.src.logger import set_host, set_api_key, set_user, set_tag, info, error
+from logger.src.common.dto.user import User
+from logger.src.common.dto.userGeo import UserGeo
+import jsonpickle
+
+def execute_method():
+ set_host('http://localhost:8080')
+ set_api_key('b4984c8de7f14b2f86f8e036456fd60c')
+ set_tag('os.name', 'python OS')
+ set_user(User(
+ "13213231",
+ "111.11.1.11",
+ UserGeo(
+ "1044",
+ "Baku",
+ "Gadabay"
+ )
+ ))
+
+ response = info('hi from python env')
+ print(response.status_code)
+ print(jsonpickle.encode(response))
+
+execute_method()
+```
+
+%prep
+%autosetup -n alertnow-python-1.3.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-alertnow-python -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.3-1
+- Package Spec generated