summaryrefslogtreecommitdiff
path: root/python-algopack.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-algopack.spec')
-rw-r--r--python-algopack.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-algopack.spec b/python-algopack.spec
new file mode 100644
index 0000000..a5ffbc8
--- /dev/null
+++ b/python-algopack.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-algopack
+Version: 0.0.4
+Release: 1
+Summary: Implementation of various common CS algortihms in Cython
+License: MIT
+URL: https://github.com/divykj/algopack
+Source0: https://mirrors.aliyun.com/pypi/web/packages/3b/0f/c597fc93dda4c384a847ea8e26bb9c0a7b660239ba9e739d8c48f72fb87e/algopack-0.0.4.tar.gz
+
+Requires: python3-doit
+Requires: python3-pytest
+Requires: python3-Cython
+Requires: python3-twine
+
+%description
+
+
+%package -n python3-algopack
+Summary: Implementation of various common CS algortihms in Cython
+Provides: python-algopack
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-algopack
+
+
+%package help
+Summary: Development documents and examples for algopack
+Provides: python3-algopack-doc
+%description help
+
+
+%prep
+%autosetup -n algopack-0.0.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-algopack -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.4-1
+- Package Spec generated