summaryrefslogtreecommitdiff
path: root/python-aloe-webdriver.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aloe-webdriver.spec')
-rw-r--r--python-aloe-webdriver.spec101
1 files changed, 101 insertions, 0 deletions
diff --git a/python-aloe-webdriver.spec b/python-aloe-webdriver.spec
new file mode 100644
index 0000000..5b978f6
--- /dev/null
+++ b/python-aloe-webdriver.spec
@@ -0,0 +1,101 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aloe-webdriver
+Version: 0.6.0
+Release: 1
+Summary: Selenium webdriver extension for Aloe
+License: MIT License
+URL: https://github.com/aloetesting/aloe_webdriver/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/05/30/9cfe29e598b95ed3aa892b5dbf191e1b2c4e4ac692169fe29624f5fed448/aloe_webdriver-0.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-aloe
+Requires: python3-selenium
+
+%description
+[![Build status](https://img.shields.io/travis/aloetesting/aloe_webdriver.svg)](https://travis-ci.org/aloetesting/aloe_webdriver)
+[![Coverage](https://img.shields.io/coveralls/aloetesting/aloe_webdriver.svg)](https://coveralls.io/github/aloetesting/aloe_webdriver)
+[![PyPI](https://img.shields.io/pypi/v/aloe_webdriver.svg)](https://pypi.python.org/pypi/aloe_webdriver)
+A set of [Gherkin][gherkin] steps for use with [Aloe][aloe] to test Web
+applications using Selenium.
+Based on [lettuce_webdriver][lettuce_webdriver] which, in turn, is inspired by
+[cucumber_watir][cucumber_watir].
+Install:
+ pip install aloe_webdriver
+Read the [documentation][documentation].
+
+%package -n python3-aloe-webdriver
+Summary: Selenium webdriver extension for Aloe
+Provides: python-aloe-webdriver
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aloe-webdriver
+[![Build status](https://img.shields.io/travis/aloetesting/aloe_webdriver.svg)](https://travis-ci.org/aloetesting/aloe_webdriver)
+[![Coverage](https://img.shields.io/coveralls/aloetesting/aloe_webdriver.svg)](https://coveralls.io/github/aloetesting/aloe_webdriver)
+[![PyPI](https://img.shields.io/pypi/v/aloe_webdriver.svg)](https://pypi.python.org/pypi/aloe_webdriver)
+A set of [Gherkin][gherkin] steps for use with [Aloe][aloe] to test Web
+applications using Selenium.
+Based on [lettuce_webdriver][lettuce_webdriver] which, in turn, is inspired by
+[cucumber_watir][cucumber_watir].
+Install:
+ pip install aloe_webdriver
+Read the [documentation][documentation].
+
+%package help
+Summary: Development documents and examples for aloe-webdriver
+Provides: python3-aloe-webdriver-doc
+%description help
+[![Build status](https://img.shields.io/travis/aloetesting/aloe_webdriver.svg)](https://travis-ci.org/aloetesting/aloe_webdriver)
+[![Coverage](https://img.shields.io/coveralls/aloetesting/aloe_webdriver.svg)](https://coveralls.io/github/aloetesting/aloe_webdriver)
+[![PyPI](https://img.shields.io/pypi/v/aloe_webdriver.svg)](https://pypi.python.org/pypi/aloe_webdriver)
+A set of [Gherkin][gherkin] steps for use with [Aloe][aloe] to test Web
+applications using Selenium.
+Based on [lettuce_webdriver][lettuce_webdriver] which, in turn, is inspired by
+[cucumber_watir][cucumber_watir].
+Install:
+ pip install aloe_webdriver
+Read the [documentation][documentation].
+
+%prep
+%autosetup -n aloe-webdriver-0.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aloe-webdriver -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0-1
+- Package Spec generated