summaryrefslogtreecommitdiff
path: root/python-amigocloud.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-amigocloud.spec')
-rw-r--r--python-amigocloud.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-amigocloud.spec b/python-amigocloud.spec
new file mode 100644
index 0000000..6f6d28b
--- /dev/null
+++ b/python-amigocloud.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-amigocloud
+Version: 1.2.5
+Release: 1
+Summary: Python client for the AmigoCloud REST API
+License: MIT
+URL: https://github.com/amigocloud/python-amigocloud
+Source0: https://mirrors.aliyun.com/pypi/web/packages/cf/b8/032ea77acc27aeb2fc75b85ada91f171e00a462127131edc1cb083672020/amigocloud-1.2.5.tar.gz
+BuildArch: noarch
+
+
+%description
+Python client for the `AmigoCloud <https://www.amigocloud.com>`__ REST
+API.
+
+%package -n python3-amigocloud
+Summary: Python client for the AmigoCloud REST API
+Provides: python-amigocloud
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-amigocloud
+Python client for the `AmigoCloud <https://www.amigocloud.com>`__ REST
+API.
+
+%package help
+Summary: Development documents and examples for amigocloud
+Provides: python3-amigocloud-doc
+%description help
+Python client for the `AmigoCloud <https://www.amigocloud.com>`__ REST
+API.
+
+%prep
+%autosetup -n amigocloud-1.2.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-amigocloud -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.5-1
+- Package Spec generated