summaryrefslogtreecommitdiff
path: root/python-amocrm-talenttech-oss.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-amocrm-talenttech-oss.spec')
-rw-r--r--python-amocrm-talenttech-oss.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-amocrm-talenttech-oss.spec b/python-amocrm-talenttech-oss.spec
new file mode 100644
index 0000000..9623225
--- /dev/null
+++ b/python-amocrm-talenttech-oss.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-amocrm-talenttech-oss
+Version: 0.4.1
+Release: 1
+Summary: Library for retrieving and uploading to database data from amocrm API
+License: MIT
+URL: https://github.com/severgroup-tt/topmind-commons/tree/master/py/amocrm
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/54/20/03305951a1c421e0c2d62d4ffc592a4fc793a7f59eaf5b62a06aee99fef1/amocrm-talenttech-oss-0.4.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-etl-helper-talenttech
+Requires: python3-s3-talenttech-oss
+Requires: python3-swap-inserter-talenttech-oss
+Requires: python3-clickhouse-balanced-talenttech-oss
+Requires: python3-requests
+Requires: python3-vertica-connector-talenttech
+
+%description
+1. Retrieving data from amocrm amocrm.api (v2 and v4).
+2. Uploading data to database.
+
+%package -n python3-amocrm-talenttech-oss
+Summary: Library for retrieving and uploading to database data from amocrm API
+Provides: python-amocrm-talenttech-oss
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-amocrm-talenttech-oss
+1. Retrieving data from amocrm amocrm.api (v2 and v4).
+2. Uploading data to database.
+
+%package help
+Summary: Development documents and examples for amocrm-talenttech-oss
+Provides: python3-amocrm-talenttech-oss-doc
+%description help
+1. Retrieving data from amocrm amocrm.api (v2 and v4).
+2. Uploading data to database.
+
+%prep
+%autosetup -n amocrm-talenttech-oss-0.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-amocrm-talenttech-oss -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.1-1
+- Package Spec generated