summaryrefslogtreecommitdiff
path: root/python-amplpy-cplex.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-amplpy-cplex.spec')
-rw-r--r--python-amplpy-cplex.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-amplpy-cplex.spec b/python-amplpy-cplex.spec
new file mode 100644
index 0000000..b840055
--- /dev/null
+++ b/python-amplpy-cplex.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-amplpy-cplex
+Version: 0.1.0b18
+Release: 1
+Summary: CPLEX extension for amplpy
+License: BSD-3
+URL: http://ampl.com/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dd/5a/d25e9c451d364abde28cbc94f05f82f25987b5f66e0d5450677e8d247726/amplpy_cplex-0.1.0b18.tar.gz
+
+
+%description
+CPLEX driver for AMPL. This package uses AMPLS-API, which is an open source set of lightweight
+interfaces between AMPL and solvers, which allow:
+- Read in an AMPL model instance from an `NL` file
+- Write out the solution as a `sol` file, ready to be imported by AMPL
+- A choiche between:
+ - Use of all the solver's capabilities, using its own C API functionalities
+ - Use of a (provided) generic interface, that encapsulates the most common
+ functionalities of the solver interfaces, permitting hassle-free solver swap
+- Usage of existing AMPL licenses, when used together with the AMPL drivers
+The interfaces are available for multiple languages; the core is written in C++ and it is wrapped using
+[swig](https://www.swig.org) to other target languages.
+
+%package -n python3-amplpy-cplex
+Summary: CPLEX extension for amplpy
+Provides: python-amplpy-cplex
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-amplpy-cplex
+CPLEX driver for AMPL. This package uses AMPLS-API, which is an open source set of lightweight
+interfaces between AMPL and solvers, which allow:
+- Read in an AMPL model instance from an `NL` file
+- Write out the solution as a `sol` file, ready to be imported by AMPL
+- A choiche between:
+ - Use of all the solver's capabilities, using its own C API functionalities
+ - Use of a (provided) generic interface, that encapsulates the most common
+ functionalities of the solver interfaces, permitting hassle-free solver swap
+- Usage of existing AMPL licenses, when used together with the AMPL drivers
+The interfaces are available for multiple languages; the core is written in C++ and it is wrapped using
+[swig](https://www.swig.org) to other target languages.
+
+%package help
+Summary: Development documents and examples for amplpy-cplex
+Provides: python3-amplpy-cplex-doc
+%description help
+CPLEX driver for AMPL. This package uses AMPLS-API, which is an open source set of lightweight
+interfaces between AMPL and solvers, which allow:
+- Read in an AMPL model instance from an `NL` file
+- Write out the solution as a `sol` file, ready to be imported by AMPL
+- A choiche between:
+ - Use of all the solver's capabilities, using its own C API functionalities
+ - Use of a (provided) generic interface, that encapsulates the most common
+ functionalities of the solver interfaces, permitting hassle-free solver swap
+- Usage of existing AMPL licenses, when used together with the AMPL drivers
+The interfaces are available for multiple languages; the core is written in C++ and it is wrapped using
+[swig](https://www.swig.org) to other target languages.
+
+%prep
+%autosetup -n amplpy-cplex-0.1.0b18
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-amplpy-cplex -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.0b18-1
+- Package Spec generated