summaryrefslogtreecommitdiff
path: root/python-analytics-python.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-analytics-python.spec')
-rw-r--r--python-analytics-python.spec119
1 files changed, 119 insertions, 0 deletions
diff --git a/python-analytics-python.spec b/python-analytics-python.spec
new file mode 100644
index 0000000..88cc75a
--- /dev/null
+++ b/python-analytics-python.spec
@@ -0,0 +1,119 @@
+%global _empty_manifest_terminate_build 0
+Name: python-analytics-python
+Version: 1.4.post1
+Release: 1
+Summary: The hassle-free way to integrate analytics into any python application.
+License: MIT License
+URL: https://github.com/segmentio/analytics-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/52/f2/6e06e01b5ed7806286e301287ebc0fda39e8b1da47a3cfa50eb62174d233/analytics-python-1.4.post1.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-six
+Requires: python3-monotonic
+Requires: python3-backoff
+Requires: python3-dateutil
+Requires: python3-mock
+Requires: python3-pylint
+Requires: python3-flake8
+
+%description
+
+This library was renamed due to a naming conflict with an official python library.
+Please use the new listing at https://pypi.org/project/segment-analytics-python/
+
+Segment is the simplest way to integrate analytics into your application.
+One API allows you to turn on any other analytics service. No more learning
+new APIs, repeated code, and wasted development time.
+
+This is the official python client that wraps the Segment REST API (https://segment.com).
+
+Documentation and more details at https://github.com/segmentio/analytics-python
+
+
+
+
+%package -n python3-analytics-python
+Summary: The hassle-free way to integrate analytics into any python application.
+Provides: python-analytics-python
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-analytics-python
+
+This library was renamed due to a naming conflict with an official python library.
+Please use the new listing at https://pypi.org/project/segment-analytics-python/
+
+Segment is the simplest way to integrate analytics into your application.
+One API allows you to turn on any other analytics service. No more learning
+new APIs, repeated code, and wasted development time.
+
+This is the official python client that wraps the Segment REST API (https://segment.com).
+
+Documentation and more details at https://github.com/segmentio/analytics-python
+
+
+
+
+%package help
+Summary: Development documents and examples for analytics-python
+Provides: python3-analytics-python-doc
+%description help
+
+This library was renamed due to a naming conflict with an official python library.
+Please use the new listing at https://pypi.org/project/segment-analytics-python/
+
+Segment is the simplest way to integrate analytics into your application.
+One API allows you to turn on any other analytics service. No more learning
+new APIs, repeated code, and wasted development time.
+
+This is the official python client that wraps the Segment REST API (https://segment.com).
+
+Documentation and more details at https://github.com/segmentio/analytics-python
+
+
+
+
+%prep
+%autosetup -n analytics-python-1.4.post1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-analytics-python -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.post1-1
+- Package Spec generated