summaryrefslogtreecommitdiff
path: root/python-anymarkup-core.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-anymarkup-core.spec')
-rw-r--r--python-anymarkup-core.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-anymarkup-core.spec b/python-anymarkup-core.spec
new file mode 100644
index 0000000..c59e7f7
--- /dev/null
+++ b/python-anymarkup-core.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-anymarkup-core
+Version: 0.8.1
+Release: 1
+Summary: Core library for anymarkup
+License: BSD
+URL: https://github.com/bkabrda/anymarkup-core
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e3/6a/df5abb31479b36b75aa4041e62fdd2f52810fe08f7e2ef5a9883459cf97e/anymarkup-core-0.8.1.tar.gz
+BuildArch: noarch
+
+
+%description
+This is the core library that implements functionality of https://github.com/bkabrda/anymarkup.
+You can install this if you only want to use a subset of anymarkup parsers. For example, you
+can do this::
+ $ pip install anymarkup-core PyYAML
+ $ python -c "import anymarkup_core; print(anymarkup_core.parse('foo: bar'))"
+in the same way you use anymarkup, except you have to import from `anymarkup_core`, obviously.
+
+%package -n python3-anymarkup-core
+Summary: Core library for anymarkup
+Provides: python-anymarkup-core
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-anymarkup-core
+This is the core library that implements functionality of https://github.com/bkabrda/anymarkup.
+You can install this if you only want to use a subset of anymarkup parsers. For example, you
+can do this::
+ $ pip install anymarkup-core PyYAML
+ $ python -c "import anymarkup_core; print(anymarkup_core.parse('foo: bar'))"
+in the same way you use anymarkup, except you have to import from `anymarkup_core`, obviously.
+
+%package help
+Summary: Development documents and examples for anymarkup-core
+Provides: python3-anymarkup-core-doc
+%description help
+This is the core library that implements functionality of https://github.com/bkabrda/anymarkup.
+You can install this if you only want to use a subset of anymarkup parsers. For example, you
+can do this::
+ $ pip install anymarkup-core PyYAML
+ $ python -c "import anymarkup_core; print(anymarkup_core.parse('foo: bar'))"
+in the same way you use anymarkup, except you have to import from `anymarkup_core`, obviously.
+
+%prep
+%autosetup -n anymarkup-core-0.8.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-anymarkup-core -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.1-1
+- Package Spec generated