summaryrefslogtreecommitdiff
path: root/python-anymarkup.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-anymarkup.spec')
-rw-r--r--python-anymarkup.spec144
1 files changed, 144 insertions, 0 deletions
diff --git a/python-anymarkup.spec b/python-anymarkup.spec
new file mode 100644
index 0000000..5bda3c6
--- /dev/null
+++ b/python-anymarkup.spec
@@ -0,0 +1,144 @@
+%global _empty_manifest_terminate_build 0
+Name: python-anymarkup
+Version: 0.8.1
+Release: 1
+Summary: Parse/serialize any markup format
+License: BSD
+URL: https://github.com/bkabrda/anymarkup
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/23/cd/33df5e9ce5dcf72a55e39432a0d6bbc77aa7857b536a063c368aa48bdd8f/anymarkup-0.8.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Parse or serialize any markup. Currently supports ini, json, json5, toml, xml and yaml.
+Report bugs and new functionality requests at https://github.com/bkabrda/anymarkup/issues.
+Parsing::
+ >>> import anymarkup
+ >>> anymarkup.parse('foo: bar')
+ {'foo': 'bar'}
+ >>> anymarkup.parse_file('foo/bar.ini')
+ {'section': {'subsection': {'opt2': 'bar'}, 'opt1': 'foo'}}
+ $ cat foo/bar.ini
+ [section]
+ opt1=foo
+ [[subsection]]
+ opt2=bar
+Serializing::
+ >>> import anymarkup
+ >>> anymarkup.serialize({'foo': 'bar'}, 'json')
+ b'{\n "foo": "bar"\n}'
+ >>> anymarkup.serialize_file({'foo': 'bar'}, 'foo/bar.json')
+ $ cat foo/bar.json
+ {
+ "foo": "bar"
+ }
+``anymarkup`` is licensed under BSD license. You can download official releases
+from https://pypi.python.org/pypi/anymarkup or install them via ``pip install anymarkup``.
+``anymarkup`` works with Python 2.7 and >= 3.3.
+
+%package -n python3-anymarkup
+Summary: Parse/serialize any markup format
+Provides: python-anymarkup
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-anymarkup
+Parse or serialize any markup. Currently supports ini, json, json5, toml, xml and yaml.
+Report bugs and new functionality requests at https://github.com/bkabrda/anymarkup/issues.
+Parsing::
+ >>> import anymarkup
+ >>> anymarkup.parse('foo: bar')
+ {'foo': 'bar'}
+ >>> anymarkup.parse_file('foo/bar.ini')
+ {'section': {'subsection': {'opt2': 'bar'}, 'opt1': 'foo'}}
+ $ cat foo/bar.ini
+ [section]
+ opt1=foo
+ [[subsection]]
+ opt2=bar
+Serializing::
+ >>> import anymarkup
+ >>> anymarkup.serialize({'foo': 'bar'}, 'json')
+ b'{\n "foo": "bar"\n}'
+ >>> anymarkup.serialize_file({'foo': 'bar'}, 'foo/bar.json')
+ $ cat foo/bar.json
+ {
+ "foo": "bar"
+ }
+``anymarkup`` is licensed under BSD license. You can download official releases
+from https://pypi.python.org/pypi/anymarkup or install them via ``pip install anymarkup``.
+``anymarkup`` works with Python 2.7 and >= 3.3.
+
+%package help
+Summary: Development documents and examples for anymarkup
+Provides: python3-anymarkup-doc
+%description help
+Parse or serialize any markup. Currently supports ini, json, json5, toml, xml and yaml.
+Report bugs and new functionality requests at https://github.com/bkabrda/anymarkup/issues.
+Parsing::
+ >>> import anymarkup
+ >>> anymarkup.parse('foo: bar')
+ {'foo': 'bar'}
+ >>> anymarkup.parse_file('foo/bar.ini')
+ {'section': {'subsection': {'opt2': 'bar'}, 'opt1': 'foo'}}
+ $ cat foo/bar.ini
+ [section]
+ opt1=foo
+ [[subsection]]
+ opt2=bar
+Serializing::
+ >>> import anymarkup
+ >>> anymarkup.serialize({'foo': 'bar'}, 'json')
+ b'{\n "foo": "bar"\n}'
+ >>> anymarkup.serialize_file({'foo': 'bar'}, 'foo/bar.json')
+ $ cat foo/bar.json
+ {
+ "foo": "bar"
+ }
+``anymarkup`` is licensed under BSD license. You can download official releases
+from https://pypi.python.org/pypi/anymarkup or install them via ``pip install anymarkup``.
+``anymarkup`` works with Python 2.7 and >= 3.3.
+
+%prep
+%autosetup -n anymarkup-0.8.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-anymarkup -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.1-1
+- Package Spec generated