summaryrefslogtreecommitdiff
path: root/python-aom-sdk.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 09:48:44 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 09:48:44 +0000
commit36ef1074adccf6f91c75ec54473634ae756ac5e9 (patch)
tree67166d3a89b49898083155dd32a84e54a7fa9d68 /python-aom-sdk.spec
parentc7bc0c872c4e3bd44d26af5b56204093378d4784 (diff)
automatic import of python-aom-sdkopeneuler20.03
Diffstat (limited to 'python-aom-sdk.spec')
-rw-r--r--python-aom-sdk.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-aom-sdk.spec b/python-aom-sdk.spec
new file mode 100644
index 0000000..cdf8d37
--- /dev/null
+++ b/python-aom-sdk.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aom-sdk
+Version: 0.1.1
+Release: 1
+Summary: AoM platform sdk
+License: Apache License 2.0
+URL: https://gitlab.com/age-of-minds/aom-framework
+Source0: https://mirrors.aliyun.com/pypi/web/packages/6b/e3/81118070897d7e6f1af5d75d9c02a21d1cd25d59465e7af3321dafbd175a/aom_sdk-0.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+# aom_framework python SDK
+
+This is the python API for making use of the AoM framework when working with the Python programming language.
+
+%package -n python3-aom-sdk
+Summary: AoM platform sdk
+Provides: python-aom-sdk
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aom-sdk
+# aom_framework python SDK
+
+This is the python API for making use of the AoM framework when working with the Python programming language.
+
+%package help
+Summary: Development documents and examples for aom-sdk
+Provides: python3-aom-sdk-doc
+%description help
+# aom_framework python SDK
+
+This is the python API for making use of the AoM framework when working with the Python programming language.
+
+%prep
+%autosetup -n aom_sdk-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aom-sdk -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated