summaryrefslogtreecommitdiff
path: root/python-aomi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aomi.spec')
-rw-r--r--python-aomi.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-aomi.spec b/python-aomi.spec
new file mode 100644
index 0000000..4246fee
--- /dev/null
+++ b/python-aomi.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-aomi
+Version: 1.11.2
+Release: 1
+Summary: Easy access to secrets is not as bad as it sounds
+License: MIT
+URL: https://github.com/autodesk/aomi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/25/13/8246afef64138eb9b249c7a1bafd874508725f02f01df4cce62ee931f7b6/aomi-1.11.2.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-aomi
+Summary: Easy access to secrets is not as bad as it sounds
+Provides: python-aomi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-aomi
+
+
+%package help
+Summary: Development documents and examples for aomi
+Provides: python3-aomi-doc
+%description help
+
+
+%prep
+%autosetup -n aomi-1.11.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-aomi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.11.2-1
+- Package Spec generated