summaryrefslogtreecommitdiff
path: root/python-api2pdf.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 09:12:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 09:12:50 +0000
commit2767aa87d89a1003505f9e9d962d7431564ef077 (patch)
treef016abf044b8a1557323de7d5a3ba3715fbcb4d7 /python-api2pdf.spec
parent852aa03e0d5aa8ecf841c2229d79ad997d896de3 (diff)
automatic import of python-api2pdf
Diffstat (limited to 'python-api2pdf.spec')
-rw-r--r--python-api2pdf.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-api2pdf.spec b/python-api2pdf.spec
new file mode 100644
index 0000000..dcf2c7c
--- /dev/null
+++ b/python-api2pdf.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-api2pdf
+Version: 2.1.0
+Release: 1
+Summary: This client library is a wrapper for the Api2Pdf.com REST API. See full REST api documentation at https://www.api2pdf.com/documentation/v2. Api2Pdf is a powerful API that supports HTML to PDF, URL to PDF, HTML to Image, URL to Image, Thumbnail / image preview of an Office file, Office files (Word to PDF), HTML to Docx, HTML to excel, PDF to HTML, merge PDFs together, add bookmarks to PDFs, add passwords to PDFs
+License: MIT License
+URL: https://github.com/api2pdf/api2pdf.python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/68/d1/73ccf8d9fc119998f7d741575f12987fe1c20337387da95f0ddf7c517c5e/api2pdf-2.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+ - Headers: {'Authorization': 'YOUR-API-KEY'}
+ - Endpoint: https://v2018.api2pdf.com/chrome/html
+ - Payload:
+
+%package -n python3-api2pdf
+Summary: This client library is a wrapper for the Api2Pdf.com REST API. See full REST api documentation at https://www.api2pdf.com/documentation/v2. Api2Pdf is a powerful API that supports HTML to PDF, URL to PDF, HTML to Image, URL to Image, Thumbnail / image preview of an Office file, Office files (Word to PDF), HTML to Docx, HTML to excel, PDF to HTML, merge PDFs together, add bookmarks to PDFs, add passwords to PDFs
+Provides: python-api2pdf
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-api2pdf
+ - Headers: {'Authorization': 'YOUR-API-KEY'}
+ - Endpoint: https://v2018.api2pdf.com/chrome/html
+ - Payload:
+
+%package help
+Summary: Development documents and examples for api2pdf
+Provides: python3-api2pdf-doc
+%description help
+ - Headers: {'Authorization': 'YOUR-API-KEY'}
+ - Endpoint: https://v2018.api2pdf.com/chrome/html
+ - Payload:
+
+%prep
+%autosetup -n api2pdf-2.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-api2pdf -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
+- Package Spec generated