summaryrefslogtreecommitdiff
path: root/python-apscheduler.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 09:10:01 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 09:10:01 +0000
commit05adfc4f1b53a105c03a7c3ad0dcf521ed4d69d1 (patch)
tree8b4b1c588c012d6d81d7c98083aca0b0a08222db /python-apscheduler.spec
parentf3e97e57276aa14eeff3723445df6de39e483249 (diff)
automatic import of python-apscheduler
Diffstat (limited to 'python-apscheduler.spec')
-rw-r--r--python-apscheduler.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-apscheduler.spec b/python-apscheduler.spec
new file mode 100644
index 0000000..08d51dc
--- /dev/null
+++ b/python-apscheduler.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-APScheduler
+Version: 3.10.1
+Release: 1
+Summary: In-process task scheduler with Cron-like capabilities
+License: MIT
+URL: https://github.com/agronholm/apscheduler
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/ed/f1ad88e88208c24db80dcaae7a5a339bb283956984f8fa59933d2806413a/APScheduler-3.10.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-setuptools
+Requires: python3-six
+Requires: python3-pytz
+Requires: python3-tzlocal
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-gevent
+Requires: python3-pymongo
+Requires: python3-redis
+Requires: python3-rethinkdb
+Requires: python3-sqlalchemy
+Requires: python3-pytest
+Requires: python3-pytest-asyncio
+Requires: python3-pytest-cov
+Requires: python3-pytest-tornado5
+Requires: python3-tornado
+Requires: python3-twisted
+Requires: python3-kazoo
+
+%description
+Documentation can be found `here <https://apscheduler.readthedocs.io/>`_.
+
+%package -n python3-APScheduler
+Summary: In-process task scheduler with Cron-like capabilities
+Provides: python-APScheduler
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-APScheduler
+Documentation can be found `here <https://apscheduler.readthedocs.io/>`_.
+
+%package help
+Summary: Development documents and examples for APScheduler
+Provides: python3-APScheduler-doc
+%description help
+Documentation can be found `here <https://apscheduler.readthedocs.io/>`_.
+
+%prep
+%autosetup -n APScheduler-3.10.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-APScheduler -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.10.1-1
+- Package Spec generated