summaryrefslogtreecommitdiff
path: root/python-apycula.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-apycula.spec')
-rw-r--r--python-apycula.spec48
1 files changed, 39 insertions, 9 deletions
diff --git a/python-apycula.spec b/python-apycula.spec
index 522d049..ed3dd02 100644
--- a/python-apycula.spec
+++ b/python-apycula.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-Apycula
-Version: 0.8
+Version: 0.8.1
Release: 1
Summary: Open Source tools for Gowin FPGAs
License: MIT License
URL: https://github.com/YosysHQ/apicula
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/73/9c/64c125f9102af4883518d691fc93e5b4402785bb361b89faee8c36694177/Apycula-0.8.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/21/0f/b15f184f8345be5b85df92b5efb0ef690c3b34b4b656d38764ad49c6d6a7/Apycula-0.8.1.tar.gz
BuildArch: noarch
Requires: python3-numpy
@@ -70,6 +70,16 @@ gowin_pack -d $DEVICE -o pack.fs pnrblinky.json # chango to your device
openFPGALoader -b $BOARD pack.fs
```
+For the Tangnano9k board, you need to call nextpnr and gowin_pack with the chip family as follows:
+```
+nextpnr-gowin --json blinky.json \
+ --write pnrblinky.json \
+ --device $DEVICE \
+ --family GW1N-9C \
+ --cst $BOARD.cst
+gowin_pack -d GW1N-9C -o pack.fs pnrblinky.json
+```
+
## Getting started for contributors
In addition to the above, to run the fuzzers and build the ChipDB, the following additional dependencies are needed.
@@ -215,6 +225,16 @@ gowin_pack -d $DEVICE -o pack.fs pnrblinky.json # chango to your device
openFPGALoader -b $BOARD pack.fs
```
+For the Tangnano9k board, you need to call nextpnr and gowin_pack with the chip family as follows:
+```
+nextpnr-gowin --json blinky.json \
+ --write pnrblinky.json \
+ --device $DEVICE \
+ --family GW1N-9C \
+ --cst $BOARD.cst
+gowin_pack -d GW1N-9C -o pack.fs pnrblinky.json
+```
+
## Getting started for contributors
In addition to the above, to run the fuzzers and build the ChipDB, the following additional dependencies are needed.
@@ -357,6 +377,16 @@ gowin_pack -d $DEVICE -o pack.fs pnrblinky.json # chango to your device
openFPGALoader -b $BOARD pack.fs
```
+For the Tangnano9k board, you need to call nextpnr and gowin_pack with the chip family as follows:
+```
+nextpnr-gowin --json blinky.json \
+ --write pnrblinky.json \
+ --device $DEVICE \
+ --family GW1N-9C \
+ --cst $BOARD.cst
+gowin_pack -d GW1N-9C -o pack.fs pnrblinky.json
+```
+
## Getting started for contributors
In addition to the above, to run the fuzzers and build the ChipDB, the following additional dependencies are needed.
@@ -438,7 +468,7 @@ This project was funded through the <a href="/PET">NGI0 PET</a> Fund, a fund est
%prep
-%autosetup -n Apycula-0.8
+%autosetup -n Apycula-0.8.1
%build
%py3_build
@@ -452,20 +482,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -478,5 +508,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.1-1
- Package Spec generated