summaryrefslogtreecommitdiff
path: root/python-apypie.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:22:41 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-07 13:22:41 +0000
commit12fe6f497abcb4974b130dc9684c21d0e6908898 (patch)
treec63cc12f58d1cb96adfb18e8c94bb4291c05074d /python-apypie.spec
parent43a412405e0871b096f44cf6e0acb2949c1ae754 (diff)
automatic import of python-apypie
Diffstat (limited to 'python-apypie.spec')
-rw-r--r--python-apypie.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-apypie.spec b/python-apypie.spec
new file mode 100644
index 0000000..8b8debb
--- /dev/null
+++ b/python-apypie.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-apypie
+Version: 0.3.2
+Release: 1
+Summary: Apipie bindings for Python
+License: MIT
+URL: https://github.com/Apipie/apypie
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/19/1d/912771fd33ff1186a1fd46864fefb552f2cd76e3439429c02ae89caace7a/apypie-0.3.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+# apypie - Apipie bindings for Python
+
+[![Build Status](https://travis-ci.com/Apipie/apypie.svg?branch=master)](https://travis-ci.com/Apipie/apypie)
+[![codecov](https://codecov.io/gh/Apipie/apypie/branch/master/graph/badge.svg)](https://codecov.io/gh/Apipie/apypie)
+[![Documentation Status](https://readthedocs.org/projects/apypie/badge/?version=latest)](https://apypie.readthedocs.io/en/latest/?badge=latest)
+
+
+
+
+%package -n python3-apypie
+Summary: Apipie bindings for Python
+Provides: python-apypie
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-apypie
+# apypie - Apipie bindings for Python
+
+[![Build Status](https://travis-ci.com/Apipie/apypie.svg?branch=master)](https://travis-ci.com/Apipie/apypie)
+[![codecov](https://codecov.io/gh/Apipie/apypie/branch/master/graph/badge.svg)](https://codecov.io/gh/Apipie/apypie)
+[![Documentation Status](https://readthedocs.org/projects/apypie/badge/?version=latest)](https://apypie.readthedocs.io/en/latest/?badge=latest)
+
+
+
+
+%package help
+Summary: Development documents and examples for apypie
+Provides: python3-apypie-doc
+%description help
+# apypie - Apipie bindings for Python
+
+[![Build Status](https://travis-ci.com/Apipie/apypie.svg?branch=master)](https://travis-ci.com/Apipie/apypie)
+[![codecov](https://codecov.io/gh/Apipie/apypie/branch/master/graph/badge.svg)](https://codecov.io/gh/Apipie/apypie)
+[![Documentation Status](https://readthedocs.org/projects/apypie/badge/?version=latest)](https://apypie.readthedocs.io/en/latest/?badge=latest)
+
+
+
+
+%prep
+%autosetup -n apypie-0.3.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-apypie -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Mar 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.2-1
+- Package Spec generated