summaryrefslogtreecommitdiff
path: root/python-arbie.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 03:31:52 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 03:31:52 +0000
commit367bff5a673bb4b09dbbcdd5b29f141d1f1511b8 (patch)
tree71b79e52d80bdbcb0ebd8430b5cbc0a31a42b279 /python-arbie.spec
parentd62633eb858149b7b3ebf5c852e1c390c2ae8785 (diff)
automatic import of python-arbieopeneuler20.03
Diffstat (limited to 'python-arbie.spec')
-rw-r--r--python-arbie.spec359
1 files changed, 359 insertions, 0 deletions
diff --git a/python-arbie.spec b/python-arbie.spec
new file mode 100644
index 0000000..8e03568
--- /dev/null
+++ b/python-arbie.spec
@@ -0,0 +1,359 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Arbie
+Version: 0.10.2
+Release: 1
+Summary: please add a summary manually as the author left a blank one
+License: MIT
+URL: https://pypi.org/project/Arbie/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/22/f2/b354dd2ae4b3f21b977cc8c99104fd0b9e079b1c6448629230fa7fcef158/Arbie-0.10.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-wheel
+Requires: python3-web3
+Requires: python3-sympy
+Requires: python3-networkx
+Requires: python3-pyyaml
+Requires: python3-docopt
+Requires: python3-redis
+Requires: python3-hiredis
+Requires: python3-prometheus-client
+Requires: python3-prometheus-async
+Requires: python3-requests
+
+%description
+# Arbie
+
+[![CodeFactor](https://www.codefactor.io/repository/github/owodunni/arbie/badge?s=26f81a3989ea34700be306a9bbd3b90735e9c5ce)](https://www.codefactor.io/repository/github/owodunni/arbie) [![wemake-python-styleguide](https://img.shields.io/badge/style-wemake-000000.svg)](https://github.com/wemake-services/wemake-python-styleguide) [![codecov](https://codecov.io/gh/owodunni/arbie/branch/master/graph/badge.svg?token=76NI0XBSH1)](https://codecov.io/gh/owodunni/Arbie) [![Actions Status](https://github.com/owodunni/arbie/workflows/Python%20Branch%20Workflow/badge.svg)](https://github.com/owodunni/arbie) [![License](https://img.shields.io/github/license/owodunni/GaugeRnR)](https://github.com/owodunni/GageRnR/blob/master/LICENSE)
+[![PyPi](https://img.shields.io/pypi/v/Arbie)](https://pypi.org/project/Arbie/)
+
+
+Arbie is a greedy crypto pirate!
+
+![Arbie](./assets/icon/arbie-icon-192x192.png)
+
+## Run
+
+Run Brig with docker-compose:
+
+```
+cd Brig && docker-compose up -d
+```
+
+## Getting started
+
+## Develop
+
+Instructions for developing arbie using docker or virual-env.
+
+To setup the development environment run:
+
+```
+./gradlew venv && source .venv/bin/activate && ./gradlew setup
+```
+
+It will run the steps bellow and make sure that all tools required for Arbie
+are setup.
+
+### Docker
+
+The arbie repository can be built using docker. This is probably the simplest
+approach if you just want to get things building.
+
+```
+docker build . -t arbie
+```
+
+You can now use the newly created docker image to build and test with.
+
+test:
+```
+docker-compose run --rm arbie ./gradlew tAL
+```
+
+### Virtual-env
+
+Create a virtual env:
+```
+./gradlew venv
+```
+
+Run virual env:
+```
+source .venv/bin/activate
+```
+
+Install requirements:
+```
+./gradlew pip
+```
+
+lint:
+```
+./gradlew lint
+```
+
+### Commits
+
+Arbie works with [semantic-release](https://python-semantic-release.readthedocs.io/en/latest/)
+and therefore has a special commit style. We use [Angular style](https://github.com/angular/angular.js/blob/master/DEVELOPERS.md#commits) commits. A helpful tool for ensuring the correct commit style is [commitizen](https://github.com/commitizen/cz-cli).
+
+Simply run when commiting:
+```
+cz c
+```
+
+### Pre commit hooks
+
+To enforce code standard we use [pre-commit](https://pre-commit.com/) it manages
+pre commit hooks.
+
+Run to setup:
+```
+pre-commit install
+```
+
+
+
+
+%package -n python3-Arbie
+Summary: please add a summary manually as the author left a blank one
+Provides: python-Arbie
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Arbie
+# Arbie
+
+[![CodeFactor](https://www.codefactor.io/repository/github/owodunni/arbie/badge?s=26f81a3989ea34700be306a9bbd3b90735e9c5ce)](https://www.codefactor.io/repository/github/owodunni/arbie) [![wemake-python-styleguide](https://img.shields.io/badge/style-wemake-000000.svg)](https://github.com/wemake-services/wemake-python-styleguide) [![codecov](https://codecov.io/gh/owodunni/arbie/branch/master/graph/badge.svg?token=76NI0XBSH1)](https://codecov.io/gh/owodunni/Arbie) [![Actions Status](https://github.com/owodunni/arbie/workflows/Python%20Branch%20Workflow/badge.svg)](https://github.com/owodunni/arbie) [![License](https://img.shields.io/github/license/owodunni/GaugeRnR)](https://github.com/owodunni/GageRnR/blob/master/LICENSE)
+[![PyPi](https://img.shields.io/pypi/v/Arbie)](https://pypi.org/project/Arbie/)
+
+
+Arbie is a greedy crypto pirate!
+
+![Arbie](./assets/icon/arbie-icon-192x192.png)
+
+## Run
+
+Run Brig with docker-compose:
+
+```
+cd Brig && docker-compose up -d
+```
+
+## Getting started
+
+## Develop
+
+Instructions for developing arbie using docker or virual-env.
+
+To setup the development environment run:
+
+```
+./gradlew venv && source .venv/bin/activate && ./gradlew setup
+```
+
+It will run the steps bellow and make sure that all tools required for Arbie
+are setup.
+
+### Docker
+
+The arbie repository can be built using docker. This is probably the simplest
+approach if you just want to get things building.
+
+```
+docker build . -t arbie
+```
+
+You can now use the newly created docker image to build and test with.
+
+test:
+```
+docker-compose run --rm arbie ./gradlew tAL
+```
+
+### Virtual-env
+
+Create a virtual env:
+```
+./gradlew venv
+```
+
+Run virual env:
+```
+source .venv/bin/activate
+```
+
+Install requirements:
+```
+./gradlew pip
+```
+
+lint:
+```
+./gradlew lint
+```
+
+### Commits
+
+Arbie works with [semantic-release](https://python-semantic-release.readthedocs.io/en/latest/)
+and therefore has a special commit style. We use [Angular style](https://github.com/angular/angular.js/blob/master/DEVELOPERS.md#commits) commits. A helpful tool for ensuring the correct commit style is [commitizen](https://github.com/commitizen/cz-cli).
+
+Simply run when commiting:
+```
+cz c
+```
+
+### Pre commit hooks
+
+To enforce code standard we use [pre-commit](https://pre-commit.com/) it manages
+pre commit hooks.
+
+Run to setup:
+```
+pre-commit install
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for Arbie
+Provides: python3-Arbie-doc
+%description help
+# Arbie
+
+[![CodeFactor](https://www.codefactor.io/repository/github/owodunni/arbie/badge?s=26f81a3989ea34700be306a9bbd3b90735e9c5ce)](https://www.codefactor.io/repository/github/owodunni/arbie) [![wemake-python-styleguide](https://img.shields.io/badge/style-wemake-000000.svg)](https://github.com/wemake-services/wemake-python-styleguide) [![codecov](https://codecov.io/gh/owodunni/arbie/branch/master/graph/badge.svg?token=76NI0XBSH1)](https://codecov.io/gh/owodunni/Arbie) [![Actions Status](https://github.com/owodunni/arbie/workflows/Python%20Branch%20Workflow/badge.svg)](https://github.com/owodunni/arbie) [![License](https://img.shields.io/github/license/owodunni/GaugeRnR)](https://github.com/owodunni/GageRnR/blob/master/LICENSE)
+[![PyPi](https://img.shields.io/pypi/v/Arbie)](https://pypi.org/project/Arbie/)
+
+
+Arbie is a greedy crypto pirate!
+
+![Arbie](./assets/icon/arbie-icon-192x192.png)
+
+## Run
+
+Run Brig with docker-compose:
+
+```
+cd Brig && docker-compose up -d
+```
+
+## Getting started
+
+## Develop
+
+Instructions for developing arbie using docker or virual-env.
+
+To setup the development environment run:
+
+```
+./gradlew venv && source .venv/bin/activate && ./gradlew setup
+```
+
+It will run the steps bellow and make sure that all tools required for Arbie
+are setup.
+
+### Docker
+
+The arbie repository can be built using docker. This is probably the simplest
+approach if you just want to get things building.
+
+```
+docker build . -t arbie
+```
+
+You can now use the newly created docker image to build and test with.
+
+test:
+```
+docker-compose run --rm arbie ./gradlew tAL
+```
+
+### Virtual-env
+
+Create a virtual env:
+```
+./gradlew venv
+```
+
+Run virual env:
+```
+source .venv/bin/activate
+```
+
+Install requirements:
+```
+./gradlew pip
+```
+
+lint:
+```
+./gradlew lint
+```
+
+### Commits
+
+Arbie works with [semantic-release](https://python-semantic-release.readthedocs.io/en/latest/)
+and therefore has a special commit style. We use [Angular style](https://github.com/angular/angular.js/blob/master/DEVELOPERS.md#commits) commits. A helpful tool for ensuring the correct commit style is [commitizen](https://github.com/commitizen/cz-cli).
+
+Simply run when commiting:
+```
+cz c
+```
+
+### Pre commit hooks
+
+To enforce code standard we use [pre-commit](https://pre-commit.com/) it manages
+pre commit hooks.
+
+Run to setup:
+```
+pre-commit install
+```
+
+
+
+
+%prep
+%autosetup -n Arbie-0.10.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Arbie -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.2-1
+- Package Spec generated