summaryrefslogtreecommitdiff
path: root/python-arlo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-arlo.spec')
-rw-r--r--python-arlo.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-arlo.spec b/python-arlo.spec
new file mode 100644
index 0000000..9101ce4
--- /dev/null
+++ b/python-arlo.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-arlo
+Version: 1.2.64
+Release: 1
+Summary: Python Arlo is a library written in Python 2.7/3x which exposes the Netgear Arlo cameras via the apis that are consumed by their website.
+License: Apache Software License
+URL: https://github.com/jeffreydwalter/arlo
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f1/d9/1ec432394722f6cc662ffe99f2efeb5c9606ca64b33968f1fda3e0f99e37/arlo-1.2.64.tar.gz
+BuildArch: noarch
+
+Requires: python3-monotonic
+Requires: python3-requests
+Requires: python3-responses
+Requires: python3-urllib3
+Requires: python3-sseclient
+Requires: python3-PySocks
+Requires: python3-pickle-mixin
+Requires: python3-google-api-python-client
+Requires: python3-google-auth-oauthlib
+
+%description
+### GETTING STARTED
+Check out the [API DOCS](https://github.com/jeffreydwalter/arlo/tree/master/docs)
+**IMPORTANT:** There is a regression in `sseclient 0.0.24` that breaks this package. Please ensure you have `seeclient 0.0.22` installed.
+**IMPORTANT:** Please ensure you don't have ANY other `sseclient` packages installed in addition to `sseclient 0.0.22`! This may cause this package to fail in unexpected ways. A common one that is known to cause issues is the `sseclient-py 1.7` package. If you have a hard requirement to have more than one, please let me know and we can look into making that work.
+**IMPORTANT:** my.arlo.com requires TLS 1.2 for their API. So, if you're getting ssl errors, it's most likely related to your version of openssl. You may need to upgrade your openssl library.
+
+%package -n python3-arlo
+Summary: Python Arlo is a library written in Python 2.7/3x which exposes the Netgear Arlo cameras via the apis that are consumed by their website.
+Provides: python-arlo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-arlo
+### GETTING STARTED
+Check out the [API DOCS](https://github.com/jeffreydwalter/arlo/tree/master/docs)
+**IMPORTANT:** There is a regression in `sseclient 0.0.24` that breaks this package. Please ensure you have `seeclient 0.0.22` installed.
+**IMPORTANT:** Please ensure you don't have ANY other `sseclient` packages installed in addition to `sseclient 0.0.22`! This may cause this package to fail in unexpected ways. A common one that is known to cause issues is the `sseclient-py 1.7` package. If you have a hard requirement to have more than one, please let me know and we can look into making that work.
+**IMPORTANT:** my.arlo.com requires TLS 1.2 for their API. So, if you're getting ssl errors, it's most likely related to your version of openssl. You may need to upgrade your openssl library.
+
+%package help
+Summary: Development documents and examples for arlo
+Provides: python3-arlo-doc
+%description help
+### GETTING STARTED
+Check out the [API DOCS](https://github.com/jeffreydwalter/arlo/tree/master/docs)
+**IMPORTANT:** There is a regression in `sseclient 0.0.24` that breaks this package. Please ensure you have `seeclient 0.0.22` installed.
+**IMPORTANT:** Please ensure you don't have ANY other `sseclient` packages installed in addition to `sseclient 0.0.22`! This may cause this package to fail in unexpected ways. A common one that is known to cause issues is the `sseclient-py 1.7` package. If you have a hard requirement to have more than one, please let me know and we can look into making that work.
+**IMPORTANT:** my.arlo.com requires TLS 1.2 for their API. So, if you're getting ssl errors, it's most likely related to your version of openssl. You may need to upgrade your openssl library.
+
+%prep
+%autosetup -n arlo-1.2.64
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-arlo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.64-1
+- Package Spec generated