summaryrefslogtreecommitdiff
path: root/python-asyncpg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-asyncpg.spec')
-rw-r--r--python-asyncpg.spec108
1 files changed, 108 insertions, 0 deletions
diff --git a/python-asyncpg.spec b/python-asyncpg.spec
new file mode 100644
index 0000000..4dc2534
--- /dev/null
+++ b/python-asyncpg.spec
@@ -0,0 +1,108 @@
+%global _empty_manifest_terminate_build 0
+Name: python-asyncpg
+Version: 0.27.0
+Release: 1
+Summary: An asyncio PostgreSQL driver
+License: Apache License, Version 2.0
+URL: https://github.com/MagicStack/asyncpg
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/04/78/06b4979eb2b553a450fe38008353f5cba152a66de83c64b1639046e9ca0e/asyncpg-0.27.0.tar.gz
+
+Requires: python3-typing-extensions
+Requires: python3-Cython
+Requires: python3-pytest
+Requires: python3-Sphinx
+Requires: python3-sphinxcontrib-asyncio
+Requires: python3-sphinx-rtd-theme
+Requires: python3-flake8
+Requires: python3-uvloop
+Requires: python3-Sphinx
+Requires: python3-sphinxcontrib-asyncio
+Requires: python3-sphinx-rtd-theme
+Requires: python3-flake8
+Requires: python3-uvloop
+
+%description
+**asyncpg** is a database interface library designed specifically for
+PostgreSQL and Python/asyncio. asyncpg is an efficient, clean implementation
+of PostgreSQL server binary protocol for use with Python's ``asyncio``
+framework. You can read more about asyncpg in an introductory
+`blog post <http://magic.io/blog/asyncpg-1m-rows-from-postgres-to-python/>`_.
+asyncpg requires Python 3.7 or later and is supported for PostgreSQL
+versions 9.5 to 15. Older PostgreSQL versions or other databases implementing
+the PostgreSQL protocol *may* work, but are not being actively tested.
+
+%package -n python3-asyncpg
+Summary: An asyncio PostgreSQL driver
+Provides: python-asyncpg
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-asyncpg
+**asyncpg** is a database interface library designed specifically for
+PostgreSQL and Python/asyncio. asyncpg is an efficient, clean implementation
+of PostgreSQL server binary protocol for use with Python's ``asyncio``
+framework. You can read more about asyncpg in an introductory
+`blog post <http://magic.io/blog/asyncpg-1m-rows-from-postgres-to-python/>`_.
+asyncpg requires Python 3.7 or later and is supported for PostgreSQL
+versions 9.5 to 15. Older PostgreSQL versions or other databases implementing
+the PostgreSQL protocol *may* work, but are not being actively tested.
+
+%package help
+Summary: Development documents and examples for asyncpg
+Provides: python3-asyncpg-doc
+%description help
+**asyncpg** is a database interface library designed specifically for
+PostgreSQL and Python/asyncio. asyncpg is an efficient, clean implementation
+of PostgreSQL server binary protocol for use with Python's ``asyncio``
+framework. You can read more about asyncpg in an introductory
+`blog post <http://magic.io/blog/asyncpg-1m-rows-from-postgres-to-python/>`_.
+asyncpg requires Python 3.7 or later and is supported for PostgreSQL
+versions 9.5 to 15. Older PostgreSQL versions or other databases implementing
+the PostgreSQL protocol *may* work, but are not being actively tested.
+
+%prep
+%autosetup -n asyncpg-0.27.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-asyncpg -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.27.0-1
+- Package Spec generated