summaryrefslogtreecommitdiff
path: root/python-audioread.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-audioread.spec')
-rw-r--r--python-audioread.spec168
1 files changed, 168 insertions, 0 deletions
diff --git a/python-audioread.spec b/python-audioread.spec
new file mode 100644
index 0000000..c48de73
--- /dev/null
+++ b/python-audioread.spec
@@ -0,0 +1,168 @@
+%global _empty_manifest_terminate_build 0
+Name: python-audioread
+Version: 3.0.0
+Release: 1
+Summary: multi-library, cross-platform audio decoding
+License: MIT
+URL: https://github.com/sampsyo/audioread
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5d/cb/82a002441902dccbe427406785db07af10182245ee639ea9f4d92907c923/audioread-3.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Decode audio files using whichever backend is available. The library
+currently supports:
+- `Gstreamer`_ via `PyGObject`_.
+- `Core Audio`_ on Mac OS X via `ctypes`_. (PyObjC not required.)
+- `MAD`_ via the `pymad`_ bindings.
+- `FFmpeg`_ or `Libav`_ via its command-line interface.
+- The standard library `wave`_, `aifc`_, and `sunau`_ modules (for
+ uncompressed audio formats).
+Use the library like so::
+ with audioread.audio_open(filename) as f:
+ print(f.channels, f.samplerate, f.duration)
+ for buf in f:
+ do_something(buf)
+Buffers in the file can be accessed by iterating over the object returned from
+``audio_open``. Each buffer is a bytes-like object (``buffer``, ``bytes``, or
+``bytearray``) containing raw **16-bit little-endian signed integer PCM
+data**. (Currently, these PCM format parameters are not configurable, but this
+could be added to most of the backends.)
+Additional values are available as fields on the audio file object:
+- ``channels`` is the number of audio channels (an integer).
+- ``samplerate`` is given in Hz (an integer).
+- ``duration`` is the length of the audio in seconds (a float).
+The ``audio_open`` function transparently selects a backend that can read the
+file. (Each backend is implemented in a module inside the ``audioread``
+package.) If no backends succeed in opening the file, a ``DecodeError``
+exception is raised. This exception is only used when the file type is
+unsupported by the backends; if the file doesn't exist, a standard ``IOError``
+will be raised.
+A second optional parameter to ``audio_open`` specifies which backends to try
+(instead of trying them all, which is the default). You can use the
+``available_backends`` function to get a list backends that are usable on the
+current system.
+Audioread supports Python 3 (3.6+).
+
+%package -n python3-audioread
+Summary: multi-library, cross-platform audio decoding
+Provides: python-audioread
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-audioread
+Decode audio files using whichever backend is available. The library
+currently supports:
+- `Gstreamer`_ via `PyGObject`_.
+- `Core Audio`_ on Mac OS X via `ctypes`_. (PyObjC not required.)
+- `MAD`_ via the `pymad`_ bindings.
+- `FFmpeg`_ or `Libav`_ via its command-line interface.
+- The standard library `wave`_, `aifc`_, and `sunau`_ modules (for
+ uncompressed audio formats).
+Use the library like so::
+ with audioread.audio_open(filename) as f:
+ print(f.channels, f.samplerate, f.duration)
+ for buf in f:
+ do_something(buf)
+Buffers in the file can be accessed by iterating over the object returned from
+``audio_open``. Each buffer is a bytes-like object (``buffer``, ``bytes``, or
+``bytearray``) containing raw **16-bit little-endian signed integer PCM
+data**. (Currently, these PCM format parameters are not configurable, but this
+could be added to most of the backends.)
+Additional values are available as fields on the audio file object:
+- ``channels`` is the number of audio channels (an integer).
+- ``samplerate`` is given in Hz (an integer).
+- ``duration`` is the length of the audio in seconds (a float).
+The ``audio_open`` function transparently selects a backend that can read the
+file. (Each backend is implemented in a module inside the ``audioread``
+package.) If no backends succeed in opening the file, a ``DecodeError``
+exception is raised. This exception is only used when the file type is
+unsupported by the backends; if the file doesn't exist, a standard ``IOError``
+will be raised.
+A second optional parameter to ``audio_open`` specifies which backends to try
+(instead of trying them all, which is the default). You can use the
+``available_backends`` function to get a list backends that are usable on the
+current system.
+Audioread supports Python 3 (3.6+).
+
+%package help
+Summary: Development documents and examples for audioread
+Provides: python3-audioread-doc
+%description help
+Decode audio files using whichever backend is available. The library
+currently supports:
+- `Gstreamer`_ via `PyGObject`_.
+- `Core Audio`_ on Mac OS X via `ctypes`_. (PyObjC not required.)
+- `MAD`_ via the `pymad`_ bindings.
+- `FFmpeg`_ or `Libav`_ via its command-line interface.
+- The standard library `wave`_, `aifc`_, and `sunau`_ modules (for
+ uncompressed audio formats).
+Use the library like so::
+ with audioread.audio_open(filename) as f:
+ print(f.channels, f.samplerate, f.duration)
+ for buf in f:
+ do_something(buf)
+Buffers in the file can be accessed by iterating over the object returned from
+``audio_open``. Each buffer is a bytes-like object (``buffer``, ``bytes``, or
+``bytearray``) containing raw **16-bit little-endian signed integer PCM
+data**. (Currently, these PCM format parameters are not configurable, but this
+could be added to most of the backends.)
+Additional values are available as fields on the audio file object:
+- ``channels`` is the number of audio channels (an integer).
+- ``samplerate`` is given in Hz (an integer).
+- ``duration`` is the length of the audio in seconds (a float).
+The ``audio_open`` function transparently selects a backend that can read the
+file. (Each backend is implemented in a module inside the ``audioread``
+package.) If no backends succeed in opening the file, a ``DecodeError``
+exception is raised. This exception is only used when the file type is
+unsupported by the backends; if the file doesn't exist, a standard ``IOError``
+will be raised.
+A second optional parameter to ``audio_open`` specifies which backends to try
+(instead of trying them all, which is the default). You can use the
+``available_backends`` function to get a list backends that are usable on the
+current system.
+Audioread supports Python 3 (3.6+).
+
+%prep
+%autosetup -n audioread-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-audioread -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated