summaryrefslogtreecommitdiff
path: root/python-aurora-asi-lib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aurora-asi-lib.spec')
-rw-r--r--python-aurora-asi-lib.spec20
1 files changed, 10 insertions, 10 deletions
diff --git a/python-aurora-asi-lib.spec b/python-aurora-asi-lib.spec
index c59992e..07702e4 100644
--- a/python-aurora-asi-lib.spec
+++ b/python-aurora-asi-lib.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-aurora-asi-lib
-Version: 0.14.4
+Version: 0.16.1
Release: 1
Summary: Easily download, plot, animate, and analyze auroral all sky imager (ASI) data.
License: GNU GENERAL PUBLIC LICENSE v3.0
URL: https://github.com/mshumko/aurora-asi-lib
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1b/ee/758b148789c9244a8b547e1beed5027671c895650162628d6841120a60c1/aurora-asi-lib-0.14.4.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/a5/d7/df65c8036b3a2784ebcc7db609175af2242b58cb40b985842ece0dc1870e/aurora-asi-lib-0.16.1.tar.gz
BuildArch: noarch
Requires: python3-wheel
@@ -20,8 +20,8 @@ Requires: python3-ffmpeg-python
Requires: python3-pymap3d
Requires: python3-aacgmv2
Requires: python3-pyshp
-Requires: python3-themis-imager-readfile
Requires: python3-rego-imager-readfile
+Requires: python3-themis-imager-readfile
Requires: python3-trex-imager-readfile
%description
@@ -148,7 +148,7 @@ This library will not be possible without 1) everyone involved with designing, b
%prep
-%autosetup -n aurora-asi-lib-0.14.4
+%autosetup -n aurora-asi-lib-0.16.1
%build
%py3_build
@@ -162,20 +162,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -188,5 +188,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.14.4-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.16.1-1
- Package Spec generated