summaryrefslogtreecommitdiff
path: root/python-autoastro.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 08:52:23 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 08:52:23 +0000
commit50dc84905bec778b4521aaa3c6c6585bd7ead6a9 (patch)
treeb60645622c3de5054940e2ee6270944198c1fc64 /python-autoastro.spec
parent4d9655c05e5587ac69de5eedca58a2cd1e96f2d3 (diff)
automatic import of python-autoastro
Diffstat (limited to 'python-autoastro.spec')
-rw-r--r--python-autoastro.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-autoastro.spec b/python-autoastro.spec
new file mode 100644
index 0000000..a31d80a
--- /dev/null
+++ b/python-autoastro.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-autoastro
+Version: 0.7.2
+Release: 1
+Summary: Astro modelling
+License: MIT License
+URL: https://github.com/jammy2211/PyAutoAstro
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6f/97/8ef55e843855f437d9b2e3b31b1cc80f19e91beef455211e8e7f7dab9ece/autoastro-0.7.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-astropy
+Requires: python3-autoarray
+Requires: python3-autofit
+Requires: python3-colossus
+Requires: python3-numpy
+Requires: python3-pyquad
+Requires: python3-coverage
+Requires: python3-pytest
+Requires: python3-pytest-cov
+
+%description
+# PyAutoModel
+Libraries for model-fitting with PyAutoFit
+
+
+
+
+%package -n python3-autoastro
+Summary: Astro modelling
+Provides: python-autoastro
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-autoastro
+# PyAutoModel
+Libraries for model-fitting with PyAutoFit
+
+
+
+
+%package help
+Summary: Development documents and examples for autoastro
+Provides: python3-autoastro-doc
+%description help
+# PyAutoModel
+Libraries for model-fitting with PyAutoFit
+
+
+
+
+%prep
+%autosetup -n autoastro-0.7.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-autoastro -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.2-1
+- Package Spec generated