summaryrefslogtreecommitdiff
path: root/python-azure-cli-batch.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 05:56:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 05:56:55 +0000
commitc075cc7dd174cd9cd73c116738d15292df5a698c (patch)
tree40e7d89f14b3c17b0377e3a804dfc6e1d7ff4d7f /python-azure-cli-batch.spec
parent97c30fce831d092361659fd2ca43c2bb38be5e28 (diff)
automatic import of python-azure-cli-batchopeneuler20.03
Diffstat (limited to 'python-azure-cli-batch.spec')
-rw-r--r--python-azure-cli-batch.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-azure-cli-batch.spec b/python-azure-cli-batch.spec
new file mode 100644
index 0000000..8608d25
--- /dev/null
+++ b/python-azure-cli-batch.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-cli-batch
+Version: 4.0.3
+Release: 1
+Summary: Microsoft Azure Command-Line Tools Batch Command Module
+License: MIT
+URL: https://github.com/Azure/azure-cli
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/67/ee/5160b5fe51a396814b704a9ec6b567d7067825ac8b71063159efa0020e23/azure-cli-batch-4.0.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-batch
+Requires: python3-azure-mgmt-batch
+Requires: python3-azure-mgmt-keyvault
+Requires: python3-azure-cli-core
+Requires: python3-azure-cli-command-modules-nspkg
+
+%description
+This package is for the 'batch' module.
+i.e. 'az batch'
+
+%package -n python3-azure-cli-batch
+Summary: Microsoft Azure Command-Line Tools Batch Command Module
+Provides: python-azure-cli-batch
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-cli-batch
+This package is for the 'batch' module.
+i.e. 'az batch'
+
+%package help
+Summary: Development documents and examples for azure-cli-batch
+Provides: python3-azure-cli-batch-doc
+%description help
+This package is for the 'batch' module.
+i.e. 'az batch'
+
+%prep
+%autosetup -n azure-cli-batch-4.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-cli-batch -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.3-1
+- Package Spec generated