summaryrefslogtreecommitdiff
path: root/python-azure-cli-batchai.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-azure-cli-batchai.spec')
-rw-r--r--python-azure-cli-batchai.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-azure-cli-batchai.spec b/python-azure-cli-batchai.spec
new file mode 100644
index 0000000..bba39a6
--- /dev/null
+++ b/python-azure-cli-batchai.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-cli-batchai
+Version: 0.4.10
+Release: 1
+Summary: Microsoft Azure Batch AI Client Command-Line Tools
+License: MIT
+URL: https://github.com/Azure/azure-cli
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bd/21/0b0e5ad69b9c61e4909866ca9082f10cbf23fa787d2f3db64ae93076ef52/azure-cli-batchai-0.4.10.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-mgmt-storage
+Requires: python3-azure-mgmt-batchai
+Requires: python3-azure-storage-blob
+Requires: python3-azure-cli-core
+Requires: python3-mock
+Requires: python3-sshtunnel
+Requires: python3-azure-cli-command-modules-nspkg
+
+%description
+This package is for the `batchai` module.
+
+%package -n python3-azure-cli-batchai
+Summary: Microsoft Azure Batch AI Client Command-Line Tools
+Provides: python-azure-cli-batchai
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-cli-batchai
+This package is for the `batchai` module.
+
+%package help
+Summary: Development documents and examples for azure-cli-batchai
+Provides: python3-azure-cli-batchai-doc
+%description help
+This package is for the `batchai` module.
+
+%prep
+%autosetup -n azure-cli-batchai-0.4.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-cli-batchai -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.10-1
+- Package Spec generated