summaryrefslogtreecommitdiff
path: root/python-azure-cli-eventgrid.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-azure-cli-eventgrid.spec')
-rw-r--r--python-azure-cli-eventgrid.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-azure-cli-eventgrid.spec b/python-azure-cli-eventgrid.spec
new file mode 100644
index 0000000..fb2a97d
--- /dev/null
+++ b/python-azure-cli-eventgrid.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-cli-eventgrid
+Version: 0.2.4
+Release: 1
+Summary: Microsoft Azure Command-Line Tools EventGrid Command Module
+License: MIT
+URL: https://github.com/Azure/azure-cli
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8e/25/4fea746cb0558d3c35ab76ac40993d97a6fc06a39234e547fa689c2e5e68/azure-cli-eventgrid-0.2.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-cli-core
+Requires: python3-six
+Requires: python3-azure-mgmt-eventgrid
+Requires: python3-azure-cli-command-modules-nspkg
+
+%description
+This package is for the 'eventgrid' module.
+i.e. 'az eventgrid'
+
+%package -n python3-azure-cli-eventgrid
+Summary: Microsoft Azure Command-Line Tools EventGrid Command Module
+Provides: python-azure-cli-eventgrid
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-cli-eventgrid
+This package is for the 'eventgrid' module.
+i.e. 'az eventgrid'
+
+%package help
+Summary: Development documents and examples for azure-cli-eventgrid
+Provides: python3-azure-cli-eventgrid-doc
+%description help
+This package is for the 'eventgrid' module.
+i.e. 'az eventgrid'
+
+%prep
+%autosetup -n azure-cli-eventgrid-0.2.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-cli-eventgrid -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.4-1
+- Package Spec generated