summaryrefslogtreecommitdiff
path: root/python-azure-cli-kusto.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-azure-cli-kusto.spec')
-rw-r--r--python-azure-cli-kusto.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-azure-cli-kusto.spec b/python-azure-cli-kusto.spec
new file mode 100644
index 0000000..5aad21d
--- /dev/null
+++ b/python-azure-cli-kusto.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-cli-kusto
+Version: 0.2.3
+Release: 1
+Summary: Microsoft Azure Command-Line Tools KUSTO Command Module
+License: MIT
+URL: https://github.com/Azure/azure-cli
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e7/f8/f4d44656e46cf14a85674548f8c77efc0ac8e37786309fa1b9c166744b2f/azure-cli-kusto-0.2.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-cli-core
+Requires: python3-azure-mgmt-kusto
+Requires: python3-six
+Requires: python3-azure-cli-command-modules-nspkg
+
+%description
+Provides management capabilities for Kusto (Azure Data Explorer) clusters.
+
+%package -n python3-azure-cli-kusto
+Summary: Microsoft Azure Command-Line Tools KUSTO Command Module
+Provides: python-azure-cli-kusto
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-cli-kusto
+Provides management capabilities for Kusto (Azure Data Explorer) clusters.
+
+%package help
+Summary: Development documents and examples for azure-cli-kusto
+Provides: python3-azure-cli-kusto-doc
+%description help
+Provides management capabilities for Kusto (Azure Data Explorer) clusters.
+
+%prep
+%autosetup -n azure-cli-kusto-0.2.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-cli-kusto -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.3-1
+- Package Spec generated