summaryrefslogtreecommitdiff
path: root/python-azure-kusto-ingest.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-azure-kusto-ingest.spec')
-rw-r--r--python-azure-kusto-ingest.spec101
1 files changed, 101 insertions, 0 deletions
diff --git a/python-azure-kusto-ingest.spec b/python-azure-kusto-ingest.spec
new file mode 100644
index 0000000..b4158bb
--- /dev/null
+++ b/python-azure-kusto-ingest.spec
@@ -0,0 +1,101 @@
+%global _empty_manifest_terminate_build 0
+Name: python-azure-kusto-ingest
+Version: 4.1.3
+Release: 1
+Summary: Kusto Ingest Client
+License: MIT
+URL: https://github.com/Azure/azure-kusto-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fd/a6/9f37103cf54c224a00a9ce91ba86616c897b1b9bf512c80d423d9238ae49/azure-kusto-ingest-4.1.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-azure-kusto-data
+Requires: python3-azure-storage-blob
+Requires: python3-azure-storage-queue
+Requires: python3-tenacity
+Requires: python3-pandas
+
+%description
+ from azure.kusto.data import KustoConnectionStringBuilder, DataFormat
+ from azure.kusto.ingest import QueuedIngestClient, IngestionProperties, FileDescriptor, BlobDescriptor
+ ingestion_props = IngestionProperties(database="{database_name}", table="{table_name}", data_format=DataFormat.CSV)
+ client = QueuedIngestClient(KustoConnectionStringBuilder.with_interactive_login("https://ingest-{cluster_name}.kusto.windows.net"))
+ file_descriptor = FileDescriptor("{filename}.csv", 15360) # in this example, the raw (uncompressed) size of the data is 15KB (15360 bytes)
+ client.ingest_from_file(file_descriptor, ingestion_properties=ingestion_props)
+ client.ingest_from_file("{filename}.csv", ingestion_properties=ingestion_props)
+ blob_descriptor = BlobDescriptor("https://{path_to_blob}.csv.gz?sas", 51200) # in this example, the raw (uncompressed) size of the data is 50KB (52100 bytes)
+ client.ingest_from_blob(blob_descriptor, ingestion_properties=ingestion_props)
+
+%package -n python3-azure-kusto-ingest
+Summary: Kusto Ingest Client
+Provides: python-azure-kusto-ingest
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-azure-kusto-ingest
+ from azure.kusto.data import KustoConnectionStringBuilder, DataFormat
+ from azure.kusto.ingest import QueuedIngestClient, IngestionProperties, FileDescriptor, BlobDescriptor
+ ingestion_props = IngestionProperties(database="{database_name}", table="{table_name}", data_format=DataFormat.CSV)
+ client = QueuedIngestClient(KustoConnectionStringBuilder.with_interactive_login("https://ingest-{cluster_name}.kusto.windows.net"))
+ file_descriptor = FileDescriptor("{filename}.csv", 15360) # in this example, the raw (uncompressed) size of the data is 15KB (15360 bytes)
+ client.ingest_from_file(file_descriptor, ingestion_properties=ingestion_props)
+ client.ingest_from_file("{filename}.csv", ingestion_properties=ingestion_props)
+ blob_descriptor = BlobDescriptor("https://{path_to_blob}.csv.gz?sas", 51200) # in this example, the raw (uncompressed) size of the data is 50KB (52100 bytes)
+ client.ingest_from_blob(blob_descriptor, ingestion_properties=ingestion_props)
+
+%package help
+Summary: Development documents and examples for azure-kusto-ingest
+Provides: python3-azure-kusto-ingest-doc
+%description help
+ from azure.kusto.data import KustoConnectionStringBuilder, DataFormat
+ from azure.kusto.ingest import QueuedIngestClient, IngestionProperties, FileDescriptor, BlobDescriptor
+ ingestion_props = IngestionProperties(database="{database_name}", table="{table_name}", data_format=DataFormat.CSV)
+ client = QueuedIngestClient(KustoConnectionStringBuilder.with_interactive_login("https://ingest-{cluster_name}.kusto.windows.net"))
+ file_descriptor = FileDescriptor("{filename}.csv", 15360) # in this example, the raw (uncompressed) size of the data is 15KB (15360 bytes)
+ client.ingest_from_file(file_descriptor, ingestion_properties=ingestion_props)
+ client.ingest_from_file("{filename}.csv", ingestion_properties=ingestion_props)
+ blob_descriptor = BlobDescriptor("https://{path_to_blob}.csv.gz?sas", 51200) # in this example, the raw (uncompressed) size of the data is 50KB (52100 bytes)
+ client.ingest_from_blob(blob_descriptor, ingestion_properties=ingestion_props)
+
+%prep
+%autosetup -n azure-kusto-ingest-4.1.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-azure-kusto-ingest -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 4.1.3-1
+- Package Spec generated