summaryrefslogtreecommitdiff
path: root/python-azure-mgmt-eventhub.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-21 11:31:03 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-21 11:31:03 +0000
commit135eda3071788090dbf4ae909d6e61fa05a2f3c2 (patch)
tree4cf3167e69dad7cc37595daf1c733189c810af04 /python-azure-mgmt-eventhub.spec
parentf0734537a741bd6f723ba2dbc07cb7dc7015a105 (diff)
automatic import of python-azure-mgmt-eventhubopeneuler20.03
Diffstat (limited to 'python-azure-mgmt-eventhub.spec')
-rw-r--r--python-azure-mgmt-eventhub.spec227
1 files changed, 193 insertions, 34 deletions
diff --git a/python-azure-mgmt-eventhub.spec b/python-azure-mgmt-eventhub.spec
index 594e753..03090b2 100644
--- a/python-azure-mgmt-eventhub.spec
+++ b/python-azure-mgmt-eventhub.spec
@@ -1,41 +1,72 @@
%global _empty_manifest_terminate_build 0
Name: python-azure-mgmt-eventhub
-Version: 10.1.0
+Version: 11.0.0
Release: 1
Summary: Microsoft Azure Event Hub Management Client Library for Python
License: MIT License
URL: https://github.com/Azure/azure-sdk-for-python
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/dc/5e2ff08ecff52df3a767b62bd92eef43c94ebd7e8dccd8127df863ce2712/azure-mgmt-eventhub-10.1.0.zip
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/aa/a59ef2dc784cd723f66882bd122e85d1b671a3947fca3fab7ec2471d2611/azure-mgmt-eventhub-11.0.0.zip
BuildArch: noarch
-Requires: python3-msrest
-Requires: python3-azure-common
-Requires: python3-azure-mgmt-core
%description
# Microsoft Azure SDK for Python
This is the Microsoft Azure Event Hub Management Client Library.
-This package has been tested with Python 3.6+.
+This package has been tested with Python 3.7+.
For a more complete view of Azure libraries, see the [azure sdk python release](https://aka.ms/azsdk/python/all).
## _Disclaimer_
_Azure SDK Python packages support for Python 2.7 has ended 01 January 2022. For more information and questions, please refer to https://github.com/Azure/azure-sdk-for-python/issues/20691_
-# Usage
+## Getting started
+### Prerequisites
-To learn how to use this package, see the [quickstart guide](https://aka.ms/azsdk/python/mgmt)
+- Python 3.7+ is required to use this package.
+- [Azure subscription](https://azure.microsoft.com/free/)
+### Install the package
+```bash
+pip install azure-mgmt-eventhub
+pip install azure-identity
+```
-For docs and references, see [Python SDK References](https://docs.microsoft.com/python/api/overview/azure/event-hub?view=azure-python-preview)
-Code samples for this package can be found at [Event Hub Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com.
-Additional code samples for different Azure services are available at [Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+### Authentication
+By default, [Azure Active Directory](https://aka.ms/awps/aad) token authentication depends on correct configure of following environment variables.
-# Provide Feedback
+- `AZURE_CLIENT_ID` for Azure client ID.
+- `AZURE_TENANT_ID` for Azure tenant ID.
+- `AZURE_CLIENT_SECRET` for Azure client secret.
+
+In addition, Azure subscription ID can be configured via environment variable `AZURE_SUBSCRIPTION_ID`.
+
+With above configuration, client can be authenticated by following code:
+
+```python
+from azure.identity import DefaultAzureCredential
+from azure.mgmt.eventhub import EventHubManagementClient
+import os
+
+sub_id = os.getenv("AZURE_SUBSCRIPTION_ID")
+client = EventHubManagementClient(credential=DefaultAzureCredential(), subscription_id=sub_id)
+```
+
+## Examples
+
+Code samples for this package can be found at:
+- [Search Event Hub Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com
+- [Azure Python Mgmt SDK Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+
+
+## Troubleshooting
+
+## Next steps
+
+## Provide Feedback
If you encounter any bugs or have suggestions, please file an issue in the
[Issues](https://github.com/Azure/azure-sdk-for-python/issues)
@@ -47,6 +78,28 @@ section of the project.
# Release History
+## 11.0.0 (2023-04-14)
+
+### Features Added
+
+ - Model Eventhub has a new parameter retention_description
+
+### Breaking Changes
+
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter location
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter tags
+
+## 11.0.0b1 (2023-02-14)
+
+### Features Added
+
+ - Model Eventhub has a new parameter retention_description
+
+### Breaking Changes
+
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter location
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter tags
+
## 10.1.0 (2022-06-22)
**Features**
@@ -379,8 +432,6 @@ This wheel package is built with the azure wheel extension
- Initial Release
-
-
%package -n python3-azure-mgmt-eventhub
Summary: Microsoft Azure Event Hub Management Client Library for Python
Provides: python-azure-mgmt-eventhub
@@ -391,26 +442,60 @@ BuildRequires: python3-pip
# Microsoft Azure SDK for Python
This is the Microsoft Azure Event Hub Management Client Library.
-This package has been tested with Python 3.6+.
+This package has been tested with Python 3.7+.
For a more complete view of Azure libraries, see the [azure sdk python release](https://aka.ms/azsdk/python/all).
## _Disclaimer_
_Azure SDK Python packages support for Python 2.7 has ended 01 January 2022. For more information and questions, please refer to https://github.com/Azure/azure-sdk-for-python/issues/20691_
-# Usage
+## Getting started
+
+### Prerequisites
+
+- Python 3.7+ is required to use this package.
+- [Azure subscription](https://azure.microsoft.com/free/)
+
+### Install the package
+```bash
+pip install azure-mgmt-eventhub
+pip install azure-identity
+```
-To learn how to use this package, see the [quickstart guide](https://aka.ms/azsdk/python/mgmt)
+### Authentication
+By default, [Azure Active Directory](https://aka.ms/awps/aad) token authentication depends on correct configure of following environment variables.
+- `AZURE_CLIENT_ID` for Azure client ID.
+- `AZURE_TENANT_ID` for Azure tenant ID.
+- `AZURE_CLIENT_SECRET` for Azure client secret.
-For docs and references, see [Python SDK References](https://docs.microsoft.com/python/api/overview/azure/event-hub?view=azure-python-preview)
-Code samples for this package can be found at [Event Hub Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com.
-Additional code samples for different Azure services are available at [Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+In addition, Azure subscription ID can be configured via environment variable `AZURE_SUBSCRIPTION_ID`.
+With above configuration, client can be authenticated by following code:
-# Provide Feedback
+```python
+from azure.identity import DefaultAzureCredential
+from azure.mgmt.eventhub import EventHubManagementClient
+import os
+
+sub_id = os.getenv("AZURE_SUBSCRIPTION_ID")
+client = EventHubManagementClient(credential=DefaultAzureCredential(), subscription_id=sub_id)
+```
+
+## Examples
+
+Code samples for this package can be found at:
+- [Search Event Hub Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com
+- [Azure Python Mgmt SDK Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+
+
+## Troubleshooting
+
+## Next steps
+
+## Provide Feedback
If you encounter any bugs or have suggestions, please file an issue in the
[Issues](https://github.com/Azure/azure-sdk-for-python/issues)
@@ -422,6 +507,28 @@ section of the project.
# Release History
+## 11.0.0 (2023-04-14)
+
+### Features Added
+
+ - Model Eventhub has a new parameter retention_description
+
+### Breaking Changes
+
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter location
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter tags
+
+## 11.0.0b1 (2023-02-14)
+
+### Features Added
+
+ - Model Eventhub has a new parameter retention_description
+
+### Breaking Changes
+
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter location
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter tags
+
## 10.1.0 (2022-06-22)
**Features**
@@ -754,8 +861,6 @@ This wheel package is built with the azure wheel extension
- Initial Release
-
-
%package help
Summary: Development documents and examples for azure-mgmt-eventhub
Provides: python3-azure-mgmt-eventhub-doc
@@ -763,26 +868,60 @@ Provides: python3-azure-mgmt-eventhub-doc
# Microsoft Azure SDK for Python
This is the Microsoft Azure Event Hub Management Client Library.
-This package has been tested with Python 3.6+.
+This package has been tested with Python 3.7+.
For a more complete view of Azure libraries, see the [azure sdk python release](https://aka.ms/azsdk/python/all).
## _Disclaimer_
_Azure SDK Python packages support for Python 2.7 has ended 01 January 2022. For more information and questions, please refer to https://github.com/Azure/azure-sdk-for-python/issues/20691_
-# Usage
+## Getting started
+
+### Prerequisites
+
+- Python 3.7+ is required to use this package.
+- [Azure subscription](https://azure.microsoft.com/free/)
+
+### Install the package
+
+```bash
+pip install azure-mgmt-eventhub
+pip install azure-identity
+```
+
+### Authentication
+
+By default, [Azure Active Directory](https://aka.ms/awps/aad) token authentication depends on correct configure of following environment variables.
+- `AZURE_CLIENT_ID` for Azure client ID.
+- `AZURE_TENANT_ID` for Azure tenant ID.
+- `AZURE_CLIENT_SECRET` for Azure client secret.
-To learn how to use this package, see the [quickstart guide](https://aka.ms/azsdk/python/mgmt)
+In addition, Azure subscription ID can be configured via environment variable `AZURE_SUBSCRIPTION_ID`.
+With above configuration, client can be authenticated by following code:
+```python
+from azure.identity import DefaultAzureCredential
+from azure.mgmt.eventhub import EventHubManagementClient
+import os
-For docs and references, see [Python SDK References](https://docs.microsoft.com/python/api/overview/azure/event-hub?view=azure-python-preview)
-Code samples for this package can be found at [Event Hub Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com.
-Additional code samples for different Azure services are available at [Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+sub_id = os.getenv("AZURE_SUBSCRIPTION_ID")
+client = EventHubManagementClient(credential=DefaultAzureCredential(), subscription_id=sub_id)
+```
+## Examples
-# Provide Feedback
+Code samples for this package can be found at:
+- [Search Event Hub Management](https://docs.microsoft.com/samples/browse/?languages=python&term=Getting%20started%20-%20Managing&terms=Getting%20started%20-%20Managing) on docs.microsoft.com
+- [Azure Python Mgmt SDK Samples Repo](https://aka.ms/azsdk/python/mgmt/samples)
+
+
+## Troubleshooting
+
+## Next steps
+
+## Provide Feedback
If you encounter any bugs or have suggestions, please file an issue in the
[Issues](https://github.com/Azure/azure-sdk-for-python/issues)
@@ -794,6 +933,28 @@ section of the project.
# Release History
+## 11.0.0 (2023-04-14)
+
+### Features Added
+
+ - Model Eventhub has a new parameter retention_description
+
+### Breaking Changes
+
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter location
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter tags
+
+## 11.0.0b1 (2023-02-14)
+
+### Features Added
+
+ - Model Eventhub has a new parameter retention_description
+
+### Breaking Changes
+
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter location
+ - Model NetworkSecurityPerimeterConfiguration no longer has parameter tags
+
## 10.1.0 (2022-06-22)
**Features**
@@ -1126,10 +1287,8 @@ This wheel package is built with the azure wheel extension
- Initial Release
-
-
%prep
-%autosetup -n azure-mgmt-eventhub-10.1.0
+%autosetup -n azure-mgmt-eventhub-11.0.0
%build
%py3_build
@@ -1169,5 +1328,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 10.1.0-1
+* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 11.0.0-1
- Package Spec generated