summaryrefslogtreecommitdiff
path: root/python-b2sdk.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 04:07:15 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 04:07:15 +0000
commitd7e120bde39bb567097be2f2e8c6cfa397746067 (patch)
treea6709d6235d2445bdf330f3215a56202ecfe43c7 /python-b2sdk.spec
parent3dab07cfdac70036a190f3d788eee13c1a0fae1a (diff)
automatic import of python-b2sdk
Diffstat (limited to 'python-b2sdk.spec')
-rw-r--r--python-b2sdk.spec189
1 files changed, 189 insertions, 0 deletions
diff --git a/python-b2sdk.spec b/python-b2sdk.spec
new file mode 100644
index 0000000..b7ea840
--- /dev/null
+++ b/python-b2sdk.spec
@@ -0,0 +1,189 @@
+%global _empty_manifest_terminate_build 0
+Name: python-b2sdk
+Version: 1.19.0
+Release: 1
+Summary: Backblaze B2 SDK
+License: MIT
+URL: https://github.com/Backblaze/b2-sdk-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/26/d2/c9f0ab04ad9a91c537783a8d6e9fcae041eb02dfdffe5f361a7120696388/b2sdk-1.19.0.tar.gz
+BuildArch: noarch
+
+
+%description
+# B2 Python SDK
+&nbsp;[![Continuous Integration](https://github.com/Backblaze/b2-sdk-python/workflows/Continuous%20Integration/badge.svg)](https://github.com/Backblaze/b2-sdk-python/actions?query=workflow%3A%22Continuous+Integration%22)&nbsp;[![License](https://img.shields.io/pypi/l/b2sdk.svg?label=License)](https://pypi.python.org/pypi/b2)&nbsp;[![python versions](https://img.shields.io/pypi/pyversions/b2sdk.svg?label=python%20versions)](https://pypi.python.org/pypi/b2sdk)&nbsp;[![PyPI version](https://img.shields.io/pypi/v/b2sdk.svg?label=PyPI%20version)](https://pypi.python.org/pypi/b2sdk)&nbsp;[![Docs](https://readthedocs.org/projects/b2-sdk-python/badge/?version=master)](https://b2-sdk-python.readthedocs.io/en/master/)
+
+
+
+This repository contains a client library and a few handy utilities for easy access to all of the capabilities of B2 Cloud Storage.
+
+[B2 command-line tool](https://github.com/Backblaze/B2_Command_Line_Tool) is an example of how it can be used to provide command-line access to the B2 service, but there are many possible applications (including FUSE filesystems, storage backend drivers for backup applications etc).
+
+# Documentation
+
+The latest documentation is available on [Read the Docs](https://b2-sdk-python.readthedocs.io).
+
+# Installation
+
+The sdk can be installed with:
+
+ pip install b2sdk
+
+# Version policy
+
+b2sdk follows [Semantic Versioning](https://semver.org/) policy, so in essence the version number is MAJOR.MINOR.PATCH (for example 1.2.3) and:
+- we increase MAJOR version when we make incompatible API changes
+- we increase MINOR version when we add functionality in a backwards-compatible manner, and
+- we increase PATCH version when we make backwards-compatible bug fixes (unless someone relies on the undocumented behavior of a fixed bug)
+
+Therefore when setting up b2sdk as a dependency, please make sure to match the version appropriately, for example you could put this in your `requirements.txt` to make sure your code is compatible with the `b2sdk` version your user will get from pypi:
+
+```
+b2sdk>=0.0.0,<1.0.0
+```
+
+# Release History
+
+Please refer to the [changelog](CHANGELOG.md).
+
+# Developer Info
+
+Please see our [contributing guidelines](CONTRIBUTING.md).
+
+
+%package -n python3-b2sdk
+Summary: Backblaze B2 SDK
+Provides: python-b2sdk
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-b2sdk
+# B2 Python SDK
+&nbsp;[![Continuous Integration](https://github.com/Backblaze/b2-sdk-python/workflows/Continuous%20Integration/badge.svg)](https://github.com/Backblaze/b2-sdk-python/actions?query=workflow%3A%22Continuous+Integration%22)&nbsp;[![License](https://img.shields.io/pypi/l/b2sdk.svg?label=License)](https://pypi.python.org/pypi/b2)&nbsp;[![python versions](https://img.shields.io/pypi/pyversions/b2sdk.svg?label=python%20versions)](https://pypi.python.org/pypi/b2sdk)&nbsp;[![PyPI version](https://img.shields.io/pypi/v/b2sdk.svg?label=PyPI%20version)](https://pypi.python.org/pypi/b2sdk)&nbsp;[![Docs](https://readthedocs.org/projects/b2-sdk-python/badge/?version=master)](https://b2-sdk-python.readthedocs.io/en/master/)
+
+
+
+This repository contains a client library and a few handy utilities for easy access to all of the capabilities of B2 Cloud Storage.
+
+[B2 command-line tool](https://github.com/Backblaze/B2_Command_Line_Tool) is an example of how it can be used to provide command-line access to the B2 service, but there are many possible applications (including FUSE filesystems, storage backend drivers for backup applications etc).
+
+# Documentation
+
+The latest documentation is available on [Read the Docs](https://b2-sdk-python.readthedocs.io).
+
+# Installation
+
+The sdk can be installed with:
+
+ pip install b2sdk
+
+# Version policy
+
+b2sdk follows [Semantic Versioning](https://semver.org/) policy, so in essence the version number is MAJOR.MINOR.PATCH (for example 1.2.3) and:
+- we increase MAJOR version when we make incompatible API changes
+- we increase MINOR version when we add functionality in a backwards-compatible manner, and
+- we increase PATCH version when we make backwards-compatible bug fixes (unless someone relies on the undocumented behavior of a fixed bug)
+
+Therefore when setting up b2sdk as a dependency, please make sure to match the version appropriately, for example you could put this in your `requirements.txt` to make sure your code is compatible with the `b2sdk` version your user will get from pypi:
+
+```
+b2sdk>=0.0.0,<1.0.0
+```
+
+# Release History
+
+Please refer to the [changelog](CHANGELOG.md).
+
+# Developer Info
+
+Please see our [contributing guidelines](CONTRIBUTING.md).
+
+
+%package help
+Summary: Development documents and examples for b2sdk
+Provides: python3-b2sdk-doc
+%description help
+# B2 Python SDK
+&nbsp;[![Continuous Integration](https://github.com/Backblaze/b2-sdk-python/workflows/Continuous%20Integration/badge.svg)](https://github.com/Backblaze/b2-sdk-python/actions?query=workflow%3A%22Continuous+Integration%22)&nbsp;[![License](https://img.shields.io/pypi/l/b2sdk.svg?label=License)](https://pypi.python.org/pypi/b2)&nbsp;[![python versions](https://img.shields.io/pypi/pyversions/b2sdk.svg?label=python%20versions)](https://pypi.python.org/pypi/b2sdk)&nbsp;[![PyPI version](https://img.shields.io/pypi/v/b2sdk.svg?label=PyPI%20version)](https://pypi.python.org/pypi/b2sdk)&nbsp;[![Docs](https://readthedocs.org/projects/b2-sdk-python/badge/?version=master)](https://b2-sdk-python.readthedocs.io/en/master/)
+
+
+
+This repository contains a client library and a few handy utilities for easy access to all of the capabilities of B2 Cloud Storage.
+
+[B2 command-line tool](https://github.com/Backblaze/B2_Command_Line_Tool) is an example of how it can be used to provide command-line access to the B2 service, but there are many possible applications (including FUSE filesystems, storage backend drivers for backup applications etc).
+
+# Documentation
+
+The latest documentation is available on [Read the Docs](https://b2-sdk-python.readthedocs.io).
+
+# Installation
+
+The sdk can be installed with:
+
+ pip install b2sdk
+
+# Version policy
+
+b2sdk follows [Semantic Versioning](https://semver.org/) policy, so in essence the version number is MAJOR.MINOR.PATCH (for example 1.2.3) and:
+- we increase MAJOR version when we make incompatible API changes
+- we increase MINOR version when we add functionality in a backwards-compatible manner, and
+- we increase PATCH version when we make backwards-compatible bug fixes (unless someone relies on the undocumented behavior of a fixed bug)
+
+Therefore when setting up b2sdk as a dependency, please make sure to match the version appropriately, for example you could put this in your `requirements.txt` to make sure your code is compatible with the `b2sdk` version your user will get from pypi:
+
+```
+b2sdk>=0.0.0,<1.0.0
+```
+
+# Release History
+
+Please refer to the [changelog](CHANGELOG.md).
+
+# Developer Info
+
+Please see our [contributing guidelines](CONTRIBUTING.md).
+
+
+%prep
+%autosetup -n b2sdk-1.19.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-b2sdk -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.19.0-1
+- Package Spec generated