summaryrefslogtreecommitdiff
path: root/python-benatools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-benatools.spec')
-rw-r--r--python-benatools.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-benatools.spec b/python-benatools.spec
new file mode 100644
index 0000000..58e9546
--- /dev/null
+++ b/python-benatools.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-benatools
+Version: 0.0.117
+Release: 1
+Summary: Utilities package for XGBoost, CatBoost, LightGBM, Tensorflow and Pytorch
+License: MIT License
+URL: https://github.com/benayas1/benatools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/33/48/6f9461bd3f2454a84aff9dbad3cf56e957dce963d74f9a59963c2a709b48/benatools-0.0.117.tar.gz
+BuildArch: noarch
+
+
+%description
+
+# benatools
+[![Downloads](https://pepy.tech/badge/benatools)](https://pepy.tech/project/benatools)
+[![Downloads](https://pepy.tech/badge/benatools/month)](https://pepy.tech/project/benatools/month)
+[![Documentation Status](https://readthedocs.org/projects/benatools/badge/?version=latest)](https://benatools.readthedocs.io/en/latest/?badge=latest)
+
+This is a "wrapper" library containing utilities and resources that can be used for many purposes.
+
+I keep including code and functionality to this library, so it is still in a very very very initial stage.
+
+
+
+
+%package -n python3-benatools
+Summary: Utilities package for XGBoost, CatBoost, LightGBM, Tensorflow and Pytorch
+Provides: python-benatools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-benatools
+
+# benatools
+[![Downloads](https://pepy.tech/badge/benatools)](https://pepy.tech/project/benatools)
+[![Downloads](https://pepy.tech/badge/benatools/month)](https://pepy.tech/project/benatools/month)
+[![Documentation Status](https://readthedocs.org/projects/benatools/badge/?version=latest)](https://benatools.readthedocs.io/en/latest/?badge=latest)
+
+This is a "wrapper" library containing utilities and resources that can be used for many purposes.
+
+I keep including code and functionality to this library, so it is still in a very very very initial stage.
+
+
+
+
+%package help
+Summary: Development documents and examples for benatools
+Provides: python3-benatools-doc
+%description help
+
+# benatools
+[![Downloads](https://pepy.tech/badge/benatools)](https://pepy.tech/project/benatools)
+[![Downloads](https://pepy.tech/badge/benatools/month)](https://pepy.tech/project/benatools/month)
+[![Documentation Status](https://readthedocs.org/projects/benatools/badge/?version=latest)](https://benatools.readthedocs.io/en/latest/?badge=latest)
+
+This is a "wrapper" library containing utilities and resources that can be used for many purposes.
+
+I keep including code and functionality to this library, so it is still in a very very very initial stage.
+
+
+
+
+%prep
+%autosetup -n benatools-0.0.117
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-benatools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.117-1
+- Package Spec generated