summaryrefslogtreecommitdiff
path: root/python-beniget.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-beniget.spec')
-rw-r--r--python-beniget.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-beniget.spec b/python-beniget.spec
new file mode 100644
index 0000000..61a6040
--- /dev/null
+++ b/python-beniget.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-beniget
+Version: 0.4.1
+Release: 1
+Summary: Extract semantic information about static Python code
+License: BSD 3-Clause
+URL: https://github.com/serge-sans-paille/beniget/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/14/e7/50cbac38f77eca8efd39516be6651fdb9f3c4c0fab8cf2cf05f612578737/beniget-0.4.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-gast
+
+%description
+
+A static analyzer for Python2 and Python3 code.
+
+Beniget provides a static over-approximation of the global and
+local definitions inside Python Module/Class/Function.
+It can also compute def-use chains from each definition.
+
+
+
+%package -n python3-beniget
+Summary: Extract semantic information about static Python code
+Provides: python-beniget
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-beniget
+
+A static analyzer for Python2 and Python3 code.
+
+Beniget provides a static over-approximation of the global and
+local definitions inside Python Module/Class/Function.
+It can also compute def-use chains from each definition.
+
+
+
+%package help
+Summary: Development documents and examples for beniget
+Provides: python3-beniget-doc
+%description help
+
+A static analyzer for Python2 and Python3 code.
+
+Beniget provides a static over-approximation of the global and
+local definitions inside Python Module/Class/Function.
+It can also compute def-use chains from each definition.
+
+
+
+%prep
+%autosetup -n beniget-0.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-beniget -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.1-1
+- Package Spec generated