summaryrefslogtreecommitdiff
path: root/python-bioplots.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bioplots.spec')
-rw-r--r--python-bioplots.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-bioplots.spec b/python-bioplots.spec
new file mode 100644
index 0000000..2f85b75
--- /dev/null
+++ b/python-bioplots.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Bioplots
+Version: 0.1.6.9
+Release: 1
+Summary: A data visualization package for bioinformatians and computational biologist
+License: GNU General Public License v3 or later (GPLv3+)
+URL: https://jingxinfu.github.io/Bioplots
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/07/58/c7192fbb8d25989080657bf9ae0c8851a894b2f76974a3187834c9c40690/Bioplots-0.1.6.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-matplotlib
+Requires: python3-adjustText
+
+%description
+# Bioplots: A Bioinformatics Toolkit
+[![PyPI](https://img.shields.io/pypi/v/Bioplots?color=blue)](https://pypi.org/project/Bioplots/) ![PyPI - Format](https://img.shields.io/pypi/format/Bioplots?style=flat-square) ![PyPI - License](https://img.shields.io/pypi/l/Bioplots?color=red) [![Build Status](https://travis-ci.org/jingxinfu/Bioplots.svg?branch=master)](https://travis-ci.org/jingxinfu/Bioplots) [![PyPI - Downloads](https://img.shields.io/pypi/dm/Bioplots?color=green&label=pypi%20download&logoColor=green&style=flat-square)](https://pypi.org/project/Bioplots/)
+
+This package provides visualization functions that are frequently used by bioinformaticians.
+
+[Document](https://jingxinfu.github.io/Bioplots)
+
+
+
+
+
+%package -n python3-Bioplots
+Summary: A data visualization package for bioinformatians and computational biologist
+Provides: python-Bioplots
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Bioplots
+# Bioplots: A Bioinformatics Toolkit
+[![PyPI](https://img.shields.io/pypi/v/Bioplots?color=blue)](https://pypi.org/project/Bioplots/) ![PyPI - Format](https://img.shields.io/pypi/format/Bioplots?style=flat-square) ![PyPI - License](https://img.shields.io/pypi/l/Bioplots?color=red) [![Build Status](https://travis-ci.org/jingxinfu/Bioplots.svg?branch=master)](https://travis-ci.org/jingxinfu/Bioplots) [![PyPI - Downloads](https://img.shields.io/pypi/dm/Bioplots?color=green&label=pypi%20download&logoColor=green&style=flat-square)](https://pypi.org/project/Bioplots/)
+
+This package provides visualization functions that are frequently used by bioinformaticians.
+
+[Document](https://jingxinfu.github.io/Bioplots)
+
+
+
+
+
+%package help
+Summary: Development documents and examples for Bioplots
+Provides: python3-Bioplots-doc
+%description help
+# Bioplots: A Bioinformatics Toolkit
+[![PyPI](https://img.shields.io/pypi/v/Bioplots?color=blue)](https://pypi.org/project/Bioplots/) ![PyPI - Format](https://img.shields.io/pypi/format/Bioplots?style=flat-square) ![PyPI - License](https://img.shields.io/pypi/l/Bioplots?color=red) [![Build Status](https://travis-ci.org/jingxinfu/Bioplots.svg?branch=master)](https://travis-ci.org/jingxinfu/Bioplots) [![PyPI - Downloads](https://img.shields.io/pypi/dm/Bioplots?color=green&label=pypi%20download&logoColor=green&style=flat-square)](https://pypi.org/project/Bioplots/)
+
+This package provides visualization functions that are frequently used by bioinformaticians.
+
+[Document](https://jingxinfu.github.io/Bioplots)
+
+
+
+
+
+%prep
+%autosetup -n Bioplots-0.1.6.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Bioplots -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.6.9-1
+- Package Spec generated