summaryrefslogtreecommitdiff
path: root/python-birt-gd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-birt-gd.spec')
-rw-r--r--python-birt-gd.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/python-birt-gd.spec b/python-birt-gd.spec
new file mode 100644
index 0000000..781367e
--- /dev/null
+++ b/python-birt-gd.spec
@@ -0,0 +1,88 @@
+%global _empty_manifest_terminate_build 0
+Name: python-birt-gd
+Version: 0.1.47
+Release: 1
+Summary: BIRT is an implementation of Beta3-irt using gradient descent.
+License: GNU General Public License v3 (GPLv3)
+URL: https://github.com/Manuelfjr/birt-gd
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/8e/d4152f19e0408caeec18fb256a0b565287ba21d73de9a9a294a880550fc6/birt-gd-0.1.47.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-tensorflow
+Requires: python3-pandas
+Requires: python3-tqdm
+Requires: python3-seaborn
+Requires: python3-matplotlib
+Requires: python3-scikit-learn
+
+%description
+ | Min 1Qt Median 3Qt Max Std.Dev
+ Ability | 0.00010 0.22147 0.63389 0.73353 0.92040 0.33960
+ Difficulty | 0.01745 0.28047 0.63058 0.84190 0.98624 0.31635
+ Discrimination | 0.31464 1.28330 1.61493 2.22936 4.44645 1.02678
+
+%package -n python3-birt-gd
+Summary: BIRT is an implementation of Beta3-irt using gradient descent.
+Provides: python-birt-gd
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-birt-gd
+ | Min 1Qt Median 3Qt Max Std.Dev
+ Ability | 0.00010 0.22147 0.63389 0.73353 0.92040 0.33960
+ Difficulty | 0.01745 0.28047 0.63058 0.84190 0.98624 0.31635
+ Discrimination | 0.31464 1.28330 1.61493 2.22936 4.44645 1.02678
+
+%package help
+Summary: Development documents and examples for birt-gd
+Provides: python3-birt-gd-doc
+%description help
+ | Min 1Qt Median 3Qt Max Std.Dev
+ Ability | 0.00010 0.22147 0.63389 0.73353 0.92040 0.33960
+ Difficulty | 0.01745 0.28047 0.63058 0.84190 0.98624 0.31635
+ Discrimination | 0.31464 1.28330 1.61493 2.22936 4.44645 1.02678
+
+%prep
+%autosetup -n birt-gd-0.1.47
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-birt-gd -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.47-1
+- Package Spec generated