summaryrefslogtreecommitdiff
path: root/python-bitstruct.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 06:24:48 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 06:24:48 +0000
commit52e14b322808e378f5589a45a825e70813e82b7c (patch)
tree93dd04129e81c7e70e6d8ce22e18ab07a2345734 /python-bitstruct.spec
parent21a9f3bdebdf20a043bb74c6037eb9d90d66731e (diff)
automatic import of python-bitstruct
Diffstat (limited to 'python-bitstruct.spec')
-rw-r--r--python-bitstruct.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-bitstruct.spec b/python-bitstruct.spec
new file mode 100644
index 0000000..d8f332f
--- /dev/null
+++ b/python-bitstruct.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-bitstruct
+Version: 8.17.0
+Release: 1
+Summary: This module performs conversions between Python values and C bit field structs represented as Python byte strings.
+License: MIT
+URL: https://github.com/eerimoq/bitstruct
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/35/30/bbca95e38135ab88e95532b5b5d45287c34aa0066a9b8dd9b4f13ffdefd3/bitstruct-8.17.0.tar.gz
+BuildArch: noarch
+
+
+%description
+This module is intended to have a similar interface as the python
+struct module, but working on bits instead of primitive data types
+(char, int, ...).
+Project homepage: https://github.com/eerimoq/bitstruct
+Documentation: https://bitstruct.readthedocs.io
+
+%package -n python3-bitstruct
+Summary: This module performs conversions between Python values and C bit field structs represented as Python byte strings.
+Provides: python-bitstruct
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-bitstruct
+This module is intended to have a similar interface as the python
+struct module, but working on bits instead of primitive data types
+(char, int, ...).
+Project homepage: https://github.com/eerimoq/bitstruct
+Documentation: https://bitstruct.readthedocs.io
+
+%package help
+Summary: Development documents and examples for bitstruct
+Provides: python3-bitstruct-doc
+%description help
+This module is intended to have a similar interface as the python
+struct module, but working on bits instead of primitive data types
+(char, int, ...).
+Project homepage: https://github.com/eerimoq/bitstruct
+Documentation: https://bitstruct.readthedocs.io
+
+%prep
+%autosetup -n bitstruct-8.17.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-bitstruct -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 8.17.0-1
+- Package Spec generated