summaryrefslogtreecommitdiff
path: root/python-boddle.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 06:03:07 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 06:03:07 +0000
commit5ab4141af1e6987f5f29cfa15c9ee3fbee445a8c (patch)
tree29ea3bedfcdd0082d73c7489bcd228442e2747e7 /python-boddle.spec
parent948640f0e2806101ea9169d657e0c9a229c7ec08 (diff)
automatic import of python-boddleopeneuler20.03
Diffstat (limited to 'python-boddle.spec')
-rw-r--r--python-boddle.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-boddle.spec b/python-boddle.spec
new file mode 100644
index 0000000..8aa82ee
--- /dev/null
+++ b/python-boddle.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-boddle
+Version: 0.2.9
+Release: 1
+Summary: A unit testing tool for Python's bottle library.
+License: GNU Lesser General Public License v3 (LGPLv3)
+URL: https://github.com/keredson/boddle
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/73/79ed51ed60edbf53c3c2fb2e148fa78b7aa0a57041da0f2b7090f15aacb6/boddle-0.2.9.tar.gz
+BuildArch: noarch
+
+
+%description
+A unit testing tool for Python’s bottle library. We wrote this for our
+own testing purposes at https://www.hvst.com. Thanks
+`brenguyen711 <https://github.com/brenguyen711>`__ for the great name!
+
+%package -n python3-boddle
+Summary: A unit testing tool for Python's bottle library.
+Provides: python-boddle
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-boddle
+A unit testing tool for Python’s bottle library. We wrote this for our
+own testing purposes at https://www.hvst.com. Thanks
+`brenguyen711 <https://github.com/brenguyen711>`__ for the great name!
+
+%package help
+Summary: Development documents and examples for boddle
+Provides: python3-boddle-doc
+%description help
+A unit testing tool for Python’s bottle library. We wrote this for our
+own testing purposes at https://www.hvst.com. Thanks
+`brenguyen711 <https://github.com/brenguyen711>`__ for the great name!
+
+%prep
+%autosetup -n boddle-0.2.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-boddle -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.9-1
+- Package Spec generated