summaryrefslogtreecommitdiff
path: root/python-bottle-session.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bottle-session.spec')
-rw-r--r--python-bottle-session.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-bottle-session.spec b/python-bottle-session.spec
new file mode 100644
index 0000000..b64ebf7
--- /dev/null
+++ b/python-bottle-session.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-bottle-session
+Version: 1.0
+Release: 1
+Summary: Redis based sessions for bottle.
+License: Artistic
+URL: https://bitbucket.org/devries/bottle-session
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ec/58/ae7c23f52bd105237501ee348a8d52d937c64a2131176c7d70d5a77d2f33/bottle-session-1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-bottle
+Requires: python3-redis
+
+%description
+Bottle_session is a session manager for the Bottle microframework that
+uses a cookie to maintain your web session and stores a hash associated
+with that cookie using the redis key-value store. It is designed as a
+simple Bottle plugin.
+
+%package -n python3-bottle-session
+Summary: Redis based sessions for bottle.
+Provides: python-bottle-session
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-bottle-session
+Bottle_session is a session manager for the Bottle microframework that
+uses a cookie to maintain your web session and stores a hash associated
+with that cookie using the redis key-value store. It is designed as a
+simple Bottle plugin.
+
+%package help
+Summary: Development documents and examples for bottle-session
+Provides: python3-bottle-session-doc
+%description help
+Bottle_session is a session manager for the Bottle microframework that
+uses a cookie to maintain your web session and stores a hash associated
+with that cookie using the redis key-value store. It is designed as a
+simple Bottle plugin.
+
+%prep
+%autosetup -n bottle-session-1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-bottle-session -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0-1
+- Package Spec generated