summaryrefslogtreecommitdiff
path: root/python-braceexpand.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-braceexpand.spec')
-rw-r--r--python-braceexpand.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/python-braceexpand.spec b/python-braceexpand.spec
new file mode 100644
index 0000000..328457c
--- /dev/null
+++ b/python-braceexpand.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name: python-braceexpand
+Version: 0.1.7
+Release: 1
+Summary: Bash-style brace expansion for Python
+License: MIT
+URL: https://github.com/trendels/braceexpand
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/54/93/badd4f5ccf25209f3fef2573073da9fe4a45a3da99fca2f800f942130c0f/braceexpand-0.1.7.tar.gz
+BuildArch: noarch
+
+
+%description
+|build-status-img| |PyPI|
+Implements Brace Expansion as described in
+`bash(1) <http://man7.org/linux/man-pages/man1/bash.1.html#EXPANSION>`__,
+with the following limitations:
+- A pattern containing unbalanced braces will raise an
+ ``UnbalancedBracesError`` exception. In bash, unbalanced braces will
+ either be partly expanded or ignored.
+- A mixed-case character range like ``'{Z..a}'`` or ``'{a..Z}'`` will
+ not include the characters :literal:`[]^_\`` between ``Z`` and ``a``.
+``braceexpand`` is tested with Python 2.7, and 3.6+
+
+%package -n python3-braceexpand
+Summary: Bash-style brace expansion for Python
+Provides: python-braceexpand
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-braceexpand
+|build-status-img| |PyPI|
+Implements Brace Expansion as described in
+`bash(1) <http://man7.org/linux/man-pages/man1/bash.1.html#EXPANSION>`__,
+with the following limitations:
+- A pattern containing unbalanced braces will raise an
+ ``UnbalancedBracesError`` exception. In bash, unbalanced braces will
+ either be partly expanded or ignored.
+- A mixed-case character range like ``'{Z..a}'`` or ``'{a..Z}'`` will
+ not include the characters :literal:`[]^_\`` between ``Z`` and ``a``.
+``braceexpand`` is tested with Python 2.7, and 3.6+
+
+%package help
+Summary: Development documents and examples for braceexpand
+Provides: python3-braceexpand-doc
+%description help
+|build-status-img| |PyPI|
+Implements Brace Expansion as described in
+`bash(1) <http://man7.org/linux/man-pages/man1/bash.1.html#EXPANSION>`__,
+with the following limitations:
+- A pattern containing unbalanced braces will raise an
+ ``UnbalancedBracesError`` exception. In bash, unbalanced braces will
+ either be partly expanded or ignored.
+- A mixed-case character range like ``'{Z..a}'`` or ``'{a..Z}'`` will
+ not include the characters :literal:`[]^_\`` between ``Z`` and ``a``.
+``braceexpand`` is tested with Python 2.7, and 3.6+
+
+%prep
+%autosetup -n braceexpand-0.1.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-braceexpand -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.7-1
+- Package Spec generated