summaryrefslogtreecommitdiff
path: root/python-briefcase.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 10:52:38 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 10:52:38 +0000
commit1a26e4094e73e65bb96a1f2506129fa2fc1c5f32 (patch)
tree3b77360228a5ade7d314d7e5121dfaa4f70ed483 /python-briefcase.spec
parentbede006715811ddc63e49a6ba172fdb3f381c61d (diff)
automatic import of python-briefcaseopeneuler20.03
Diffstat (limited to 'python-briefcase.spec')
-rw-r--r--python-briefcase.spec132
1 files changed, 132 insertions, 0 deletions
diff --git a/python-briefcase.spec b/python-briefcase.spec
new file mode 100644
index 0000000..3c353a0
--- /dev/null
+++ b/python-briefcase.spec
@@ -0,0 +1,132 @@
+%global _empty_manifest_terminate_build 0
+Name: python-briefcase
+Version: 0.3.14
+Release: 1
+Summary: Tools to support converting a Python project into a standalone native application.
+License: New BSD
+URL: http://beeware.org/briefcase
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c8/85/994b7fdfdff2c91c3c7c08e6a40571d5968b324aa20444a92a5d0ad61eba/briefcase-0.3.14.tar.gz
+BuildArch: noarch
+
+Requires: python3-packaging
+Requires: python3-pip
+Requires: python3-setuptools
+Requires: python3-wheel
+Requires: python3-build
+Requires: python3-cookiecutter
+Requires: python3-GitPython
+Requires: python3-platformdirs
+Requires: python3-psutil
+Requires: python3-requests
+Requires: python3-rich
+Requires: python3-tomli-w
+Requires: python3-tomli
+Requires: python3-importlib-metadata
+Requires: python3-dmgbuild
+Requires: python3-coverage[toml]
+Requires: python3-pre-commit
+Requires: python3-pytest
+Requires: python3-pytest-tldr
+Requires: python3-setuptools-scm[toml]
+Requires: python3-tox
+Requires: python3-furo
+Requires: python3-pyenchant
+Requires: python3-sphinx
+Requires: python3-sphinx-tabs
+Requires: python3-sphinx-autobuild
+Requires: python3-sphinxcontrib-spelling
+
+%description
+Briefcase is a tool for converting a Python project into a standalone native
+application. You can package projects for:
+* Mac
+* Windows
+* Linux
+* iPhone/iPad
+* Android
+* Web
+Support for AppleTV, watchOS, and wearOS deployments is planned.
+If you want to see Briefcase in action, try the `BeeWare tutorial
+<https://beeware.readthedocs.io>`__. That tutorial walks you through the
+process of creating and packaging a new application with Briefcase.
+
+%package -n python3-briefcase
+Summary: Tools to support converting a Python project into a standalone native application.
+Provides: python-briefcase
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-briefcase
+Briefcase is a tool for converting a Python project into a standalone native
+application. You can package projects for:
+* Mac
+* Windows
+* Linux
+* iPhone/iPad
+* Android
+* Web
+Support for AppleTV, watchOS, and wearOS deployments is planned.
+If you want to see Briefcase in action, try the `BeeWare tutorial
+<https://beeware.readthedocs.io>`__. That tutorial walks you through the
+process of creating and packaging a new application with Briefcase.
+
+%package help
+Summary: Development documents and examples for briefcase
+Provides: python3-briefcase-doc
+%description help
+Briefcase is a tool for converting a Python project into a standalone native
+application. You can package projects for:
+* Mac
+* Windows
+* Linux
+* iPhone/iPad
+* Android
+* Web
+Support for AppleTV, watchOS, and wearOS deployments is planned.
+If you want to see Briefcase in action, try the `BeeWare tutorial
+<https://beeware.readthedocs.io>`__. That tutorial walks you through the
+process of creating and packaging a new application with Briefcase.
+
+%prep
+%autosetup -n briefcase-0.3.14
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-briefcase -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.14-1
+- Package Spec generated