summaryrefslogtreecommitdiff
path: root/python-brunt.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 04:42:04 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 04:42:04 +0000
commitdd2cf9786130f2a8d1a8dac4b308f42936009dea (patch)
treeafcbbac8eeafaab0d234ecb14699a4b50c75ce0c /python-brunt.spec
parent84be722a40b9298f95b4f1334fb697ed23610709 (diff)
automatic import of python-bruntopeneuler20.03
Diffstat (limited to 'python-brunt.spec')
-rw-r--r--python-brunt.spec490
1 files changed, 490 insertions, 0 deletions
diff --git a/python-brunt.spec b/python-brunt.spec
new file mode 100644
index 0000000..0888ef2
--- /dev/null
+++ b/python-brunt.spec
@@ -0,0 +1,490 @@
+%global _empty_manifest_terminate_build 0
+Name: python-brunt
+Version: 1.2.0
+Release: 1
+Summary: Unofficial python SDK for Brunt, this package allows you to control your Brunt devices from code.
+License: mit
+URL: https://github.com/eavanvalkenburg/brunt-api
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3e/78/050066a1f560ddc99e7ed2ea144cc241e0735f24e58709898e544bacfd93/brunt-1.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-importlib-metadata
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-tox
+Requires: python3-mypy
+Requires: python3-setuptools-scm
+Requires: python3-setuptools
+Requires: python3-wheel
+Requires: python3-types-requests
+
+%description
+[![PyPI version](https://badge.fury.io/py/brunt.svg)](https://badge.fury.io/py/brunt)
+
+# Brunt
+Unofficial python SDK for Brunt, based on the NPM version here https://github.com/MattJeanes/brunt-api
+
+This package allows you to control your Brunt devices from code.
+
+## Sample script
+
+This script shows the usage and how to use the output of the calls, off course if you already know the name of your device you do not need to call getThings.
+
+This script checks the current position of a blind called 'Blind' and if that is 100 (fully open), sets it to 90 and vice versa.
+
+```python
+from brunt import BruntClient, BruntClientAsync
+
+bapi = BruntClient()
+# bapi = BruntClientAsync()
+print("Calling Brunt")
+
+bapi.login('username', 'password')
+# await bapi.async_login('username', 'password')
+print(" Logged in, gettings things.")
+
+things = bapi.get_things()['things']
+# things = await bapi.async_get_things()['things']
+print(f" { len(things) } thing(s) found.")
+
+state = bapi.get_state(thing='Blind')['thing']
+# state = await bapi.async_get_state(thing='Blind')['thing']
+print(f" Current status of { state['NAME'] } is position { state['currentPosition'] }")
+newPos = 100
+if int(state['currentPosition']) == 100:
+ newPos = 90
+print(f" Setting { state['NAME'] } to position { newPos }")
+
+res = bapi.change_request_position(newPos, thing='Blind')
+# res = await bapi.async_change_request_position(newPos, thing='Blind')
+print(' Success!' if res else ' Fail!')
+
+```
+<h1 id="brunt.BruntClient">BruntClient & BruntClientAsync</h1>
+
+```python
+from brunt import BruntClient
+BruntClient(username, password)
+
+or
+
+from brunt import BruntClientAsync
+BruntClientAsync(username, password, session)
+```
+Constructor for the API wrapper.
+
+If you supply username and password here, they are stored, but not used.
+Auto logging in then does work when calling another method, no explicit login needed.
+
+:param username: the username of your Brunt account
+:param password: the password of your Brunt account
+
+Async only :param session: aiohttp.ClientSession object
+
+<h2 id="brunt.BruntClient.login">login</h2>
+
+```python
+BruntClient.login(self, username, password)
+await BruntClient.async_login(self, username, password)
+```
+Login method using username and password
+
+:param username: the username of your Brunt account
+:param password: the password of your Brunt account
+
+:return: True if successful
+:raises: errors from Requests call
+
+<h2 id="brunt.brunt.BruntClient.getThings">get_things</h2>
+
+```python
+BruntClient.get_things(self)
+await BruntClient.async_get_things(self)
+```
+Get the things registered in your account
+
+:return: List of Things
+:raises: errors from Requests call
+
+<h2 id="brunt.brunt.BruntClient.getState">get_state</h2>
+
+```python
+BruntClient.get_state(self, thing="Blind")
+await BruntClient.async_get_state(self, thing="Blind")
+```
+Get the state of a thing, by NAME or thingUri
+
+:param thing: a string with the NAME of the thing, which is then checked against the names of all the things.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+
+:return: a Thing.
+:raises: ValueError if the requested thing does not exists. NameError if not logged in. SyntaxError when
+ not exactly one of the params is given.
+
+<h2 id="brunt.brunt.BruntClient.changeRequestPosition">change_request_position</h2>
+
+```python
+BruntClient.change_request_position(self, request_position, thing="Blind")
+await BruntClient.async_change_request_position(self, request_position, thing="Blind")
+```
+Changes the position of the thing. Internally calls the changeKey method with key set to
+requestPosition and value set to request_position
+
+:param request_position: The new position for the slide (0-100)
+:param thing: a string with the name of the thing, which is then checked against the names of all the things.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+
+:return: a dict with 'result'.
+:raises: ValueError if the requested thing does not exists or the position is not between 0 and 100.
+ NameError if not logged in. SyntaxError when not exactly one of the params is given.
+
+<h2 id="brunt.brunt.BruntClient.changeKey">change_key</h2>
+
+```python
+BruntClient.change_key(self, key="requestPosition", value="100", thing="Blind")
+await BruntClient.async_change_key(self, key="requestPosition", value="100", thing="Blind")
+```
+Change a variable of the thing by supplying the key and value. Mostly included for future additions.
+
+:param key: The key of the value you want to change
+:param value: The new value
+:param thing: a string with the name of the thing, which is then checked using getThings.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+:return: a dict with 'result'.
+:raises: ValueError if the requested thing does not exists or the position is not between 0 and 100.
+ NameError if not logged in. SyntaxError when not exactly one of the params is given.
+
+
+
+
+%package -n python3-brunt
+Summary: Unofficial python SDK for Brunt, this package allows you to control your Brunt devices from code.
+Provides: python-brunt
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-brunt
+[![PyPI version](https://badge.fury.io/py/brunt.svg)](https://badge.fury.io/py/brunt)
+
+# Brunt
+Unofficial python SDK for Brunt, based on the NPM version here https://github.com/MattJeanes/brunt-api
+
+This package allows you to control your Brunt devices from code.
+
+## Sample script
+
+This script shows the usage and how to use the output of the calls, off course if you already know the name of your device you do not need to call getThings.
+
+This script checks the current position of a blind called 'Blind' and if that is 100 (fully open), sets it to 90 and vice versa.
+
+```python
+from brunt import BruntClient, BruntClientAsync
+
+bapi = BruntClient()
+# bapi = BruntClientAsync()
+print("Calling Brunt")
+
+bapi.login('username', 'password')
+# await bapi.async_login('username', 'password')
+print(" Logged in, gettings things.")
+
+things = bapi.get_things()['things']
+# things = await bapi.async_get_things()['things']
+print(f" { len(things) } thing(s) found.")
+
+state = bapi.get_state(thing='Blind')['thing']
+# state = await bapi.async_get_state(thing='Blind')['thing']
+print(f" Current status of { state['NAME'] } is position { state['currentPosition'] }")
+newPos = 100
+if int(state['currentPosition']) == 100:
+ newPos = 90
+print(f" Setting { state['NAME'] } to position { newPos }")
+
+res = bapi.change_request_position(newPos, thing='Blind')
+# res = await bapi.async_change_request_position(newPos, thing='Blind')
+print(' Success!' if res else ' Fail!')
+
+```
+<h1 id="brunt.BruntClient">BruntClient & BruntClientAsync</h1>
+
+```python
+from brunt import BruntClient
+BruntClient(username, password)
+
+or
+
+from brunt import BruntClientAsync
+BruntClientAsync(username, password, session)
+```
+Constructor for the API wrapper.
+
+If you supply username and password here, they are stored, but not used.
+Auto logging in then does work when calling another method, no explicit login needed.
+
+:param username: the username of your Brunt account
+:param password: the password of your Brunt account
+
+Async only :param session: aiohttp.ClientSession object
+
+<h2 id="brunt.BruntClient.login">login</h2>
+
+```python
+BruntClient.login(self, username, password)
+await BruntClient.async_login(self, username, password)
+```
+Login method using username and password
+
+:param username: the username of your Brunt account
+:param password: the password of your Brunt account
+
+:return: True if successful
+:raises: errors from Requests call
+
+<h2 id="brunt.brunt.BruntClient.getThings">get_things</h2>
+
+```python
+BruntClient.get_things(self)
+await BruntClient.async_get_things(self)
+```
+Get the things registered in your account
+
+:return: List of Things
+:raises: errors from Requests call
+
+<h2 id="brunt.brunt.BruntClient.getState">get_state</h2>
+
+```python
+BruntClient.get_state(self, thing="Blind")
+await BruntClient.async_get_state(self, thing="Blind")
+```
+Get the state of a thing, by NAME or thingUri
+
+:param thing: a string with the NAME of the thing, which is then checked against the names of all the things.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+
+:return: a Thing.
+:raises: ValueError if the requested thing does not exists. NameError if not logged in. SyntaxError when
+ not exactly one of the params is given.
+
+<h2 id="brunt.brunt.BruntClient.changeRequestPosition">change_request_position</h2>
+
+```python
+BruntClient.change_request_position(self, request_position, thing="Blind")
+await BruntClient.async_change_request_position(self, request_position, thing="Blind")
+```
+Changes the position of the thing. Internally calls the changeKey method with key set to
+requestPosition and value set to request_position
+
+:param request_position: The new position for the slide (0-100)
+:param thing: a string with the name of the thing, which is then checked against the names of all the things.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+
+:return: a dict with 'result'.
+:raises: ValueError if the requested thing does not exists or the position is not between 0 and 100.
+ NameError if not logged in. SyntaxError when not exactly one of the params is given.
+
+<h2 id="brunt.brunt.BruntClient.changeKey">change_key</h2>
+
+```python
+BruntClient.change_key(self, key="requestPosition", value="100", thing="Blind")
+await BruntClient.async_change_key(self, key="requestPosition", value="100", thing="Blind")
+```
+Change a variable of the thing by supplying the key and value. Mostly included for future additions.
+
+:param key: The key of the value you want to change
+:param value: The new value
+:param thing: a string with the name of the thing, which is then checked using getThings.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+:return: a dict with 'result'.
+:raises: ValueError if the requested thing does not exists or the position is not between 0 and 100.
+ NameError if not logged in. SyntaxError when not exactly one of the params is given.
+
+
+
+
+%package help
+Summary: Development documents and examples for brunt
+Provides: python3-brunt-doc
+%description help
+[![PyPI version](https://badge.fury.io/py/brunt.svg)](https://badge.fury.io/py/brunt)
+
+# Brunt
+Unofficial python SDK for Brunt, based on the NPM version here https://github.com/MattJeanes/brunt-api
+
+This package allows you to control your Brunt devices from code.
+
+## Sample script
+
+This script shows the usage and how to use the output of the calls, off course if you already know the name of your device you do not need to call getThings.
+
+This script checks the current position of a blind called 'Blind' and if that is 100 (fully open), sets it to 90 and vice versa.
+
+```python
+from brunt import BruntClient, BruntClientAsync
+
+bapi = BruntClient()
+# bapi = BruntClientAsync()
+print("Calling Brunt")
+
+bapi.login('username', 'password')
+# await bapi.async_login('username', 'password')
+print(" Logged in, gettings things.")
+
+things = bapi.get_things()['things']
+# things = await bapi.async_get_things()['things']
+print(f" { len(things) } thing(s) found.")
+
+state = bapi.get_state(thing='Blind')['thing']
+# state = await bapi.async_get_state(thing='Blind')['thing']
+print(f" Current status of { state['NAME'] } is position { state['currentPosition'] }")
+newPos = 100
+if int(state['currentPosition']) == 100:
+ newPos = 90
+print(f" Setting { state['NAME'] } to position { newPos }")
+
+res = bapi.change_request_position(newPos, thing='Blind')
+# res = await bapi.async_change_request_position(newPos, thing='Blind')
+print(' Success!' if res else ' Fail!')
+
+```
+<h1 id="brunt.BruntClient">BruntClient & BruntClientAsync</h1>
+
+```python
+from brunt import BruntClient
+BruntClient(username, password)
+
+or
+
+from brunt import BruntClientAsync
+BruntClientAsync(username, password, session)
+```
+Constructor for the API wrapper.
+
+If you supply username and password here, they are stored, but not used.
+Auto logging in then does work when calling another method, no explicit login needed.
+
+:param username: the username of your Brunt account
+:param password: the password of your Brunt account
+
+Async only :param session: aiohttp.ClientSession object
+
+<h2 id="brunt.BruntClient.login">login</h2>
+
+```python
+BruntClient.login(self, username, password)
+await BruntClient.async_login(self, username, password)
+```
+Login method using username and password
+
+:param username: the username of your Brunt account
+:param password: the password of your Brunt account
+
+:return: True if successful
+:raises: errors from Requests call
+
+<h2 id="brunt.brunt.BruntClient.getThings">get_things</h2>
+
+```python
+BruntClient.get_things(self)
+await BruntClient.async_get_things(self)
+```
+Get the things registered in your account
+
+:return: List of Things
+:raises: errors from Requests call
+
+<h2 id="brunt.brunt.BruntClient.getState">get_state</h2>
+
+```python
+BruntClient.get_state(self, thing="Blind")
+await BruntClient.async_get_state(self, thing="Blind")
+```
+Get the state of a thing, by NAME or thingUri
+
+:param thing: a string with the NAME of the thing, which is then checked against the names of all the things.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+
+:return: a Thing.
+:raises: ValueError if the requested thing does not exists. NameError if not logged in. SyntaxError when
+ not exactly one of the params is given.
+
+<h2 id="brunt.brunt.BruntClient.changeRequestPosition">change_request_position</h2>
+
+```python
+BruntClient.change_request_position(self, request_position, thing="Blind")
+await BruntClient.async_change_request_position(self, request_position, thing="Blind")
+```
+Changes the position of the thing. Internally calls the changeKey method with key set to
+requestPosition and value set to request_position
+
+:param request_position: The new position for the slide (0-100)
+:param thing: a string with the name of the thing, which is then checked against the names of all the things.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+
+:return: a dict with 'result'.
+:raises: ValueError if the requested thing does not exists or the position is not between 0 and 100.
+ NameError if not logged in. SyntaxError when not exactly one of the params is given.
+
+<h2 id="brunt.brunt.BruntClient.changeKey">change_key</h2>
+
+```python
+BruntClient.change_key(self, key="requestPosition", value="100", thing="Blind")
+await BruntClient.async_change_key(self, key="requestPosition", value="100", thing="Blind")
+```
+Change a variable of the thing by supplying the key and value. Mostly included for future additions.
+
+:param key: The key of the value you want to change
+:param value: The new value
+:param thing: a string with the name of the thing, which is then checked using getThings.
+:param thingUri: Uri (string) of the thing you are getting the state from, not checked against getThings.
+:return: a dict with 'result'.
+:raises: ValueError if the requested thing does not exists or the position is not between 0 and 100.
+ NameError if not logged in. SyntaxError when not exactly one of the params is given.
+
+
+
+
+%prep
+%autosetup -n brunt-1.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-brunt -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.0-1
+- Package Spec generated